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§ 1 Image Library Function

§ Case 1: How to draw figures by using drawing tools, and save them to Image Library?

Requirements

To draw figures with built-in drawing tools in HMI software

●● To draw Up, Down, Left and Right arrows.

●● To draw a network signal icon.

●● To draw a magnifier icon.

●● Save the completed figures to Image Library for future use.

Purpose

Through this case, understand the functions and usage of drawing tools; learn how to 
use align tool, including vertical-align, horizontal-align, horizontal center and vertical 
center; learn how to save figures to Image Library.

Programming Procedure

1. To draw Up, Down, Left and Right arrows

1)	 To draw a rectangle: From Menu bar, choose “Draw” > “Rectangle” to draw a 
rectangle with desired size.

2)	 To draw an arrow: Add two slants as part of the arrow.

3)	 From Menu bar, choose “Draw” > “Line” to draw a left slant and a right slant.

4)	 Make sure the two slants have the same width and height: Double-click the two 
slant respectively to open the “Figure” dialog box, and then set “Width” and “Height” 
under “Size” on the “Profile” tab to ensure symmetry.

5)	 Connect the two slants: From Menu bar, choose “Draw” > “Line”, and draw a line to 
connect the two slants.
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6)	 Control combination and alignment:

●● Choose the two slants and the line, and then from Menu bar, click “Edit” > “Combine” 
to combine them into a triangle.

●● Choose the triangle control and align it with the rectangle, created in step 1, in terms 
of horizontal center: From Menu bar, choose “Edit” > “Align” > “Horizontal Center”.

●● Choose the aligned triangle and rectangle control, and then from Menu bar, click 
“Edit” > “Combine” to combine them into an Up arrow.

                     

7)	 Repeat Step 1 to Step 6 to draw Left, Right and Down arrows respectively, as 
shown below:

  

2. To draw a network signal icon

1)	 To draw an arc: From Menu bar, choose “Draw” > “Arc” to draw an arc, as shown 
below:

2)	 Choose the arc, make two copies of it, resize the copies, and then place them under 
the original arc one by one.

3)	 To draw a dot: From Menu bar, choose “Draw” > “Circle” to draw a circle, and then 
fill color.

4)	 Choose the four controls and align them in terms of horizontal center: From Menu 
bar, choose “Edit” > “Horizontal Center”, and then combine them into a network 
signal icon, as shown below:
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3. To draw a magnifier icon

1)	 To draw two circles: From Menu bar, choose “Draw” > “Circle” to draw a big circle 
and a small one, and then align them in terms of horizontal center.

2)	 To draw two slants.

3)	 hoose and combine the two circles and the two slants, as shown below:

4. Save the completed figures to Image Library:

1)	 Take the arrow as an example to learn how to save figures to Image Library.

2)	 Create a new User Image Library: From Menu bar, choose “Media Lib” > “Open 
Image Library” to open “Image Library Manager” dialog box.

3)	 In this dialog box, choose “User image library” > “Add”, and then enter “arrow” as 
the library name.

4)	 Now the user image library has been successfully created. The following steps will 
show how to save figures to this library.

5)	 Save the figure to user image library: Choose the Up arrow control, click, from Menu 
bar, “Media Lib” > “Save to Library”, and then choose the created image library 
“arrow”. Fill in “Description” field as needed, set “No.” to 0 and set “Status No.” to 0.
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6)	 Repeat Step 5 to add the other three arrows into the image library, and set “Status 
No.” to 1, 2 and 3 respectively.

7)	 Now the created arrows have all been saved to the image library “arrow”, which can 
be opened by choosing, from Menu bar, “Media Lib” > “Open Image Library” > “User 
Image Library”, as shown below. This image library can be called at any time by 
other controls.
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8)	 Save the magnifier and the network signal icon to the Image Library by using the 
same method.

§ Case 2: How to Save Existing Images to Image Library?

Requirements

Save existing images to Image Library, including photos and downloaded pictures, which 
must be with BMP, JPG, or GIF format, and other formats are currently not supported.

Purpose

Learn how to save existing images to Image Library.

Understand that HMI can only support images with formats of BMP, JPG, and GIF 
currently.

Programming Procedure

1. How to Save Existing Images to Image Library?

1)	 From Menu bar, choose “Media Lib” > “Open Image Library” to open the “Image 
Library Manager” dialog box.

2)	 Choose the “User image library” tab in “Image Library Manager” dialog box, and 
then click “Add” to open “Add an Image Library” dialog box. Enter a name as 
needed (in this case, it is named “screensaver cycle images”), and then click “OK”.



Section 1 Image Library Function                                                          

- 8 -

1

3)	 Click “Add image” button at the lower right corner on the above page to open “Add 
an Image” dialog box, as shown below. Click “Browse...” button to locate the image 
folder. From “File list”, choose the images needed, and then click “Add” button. In 
this case, 5 images will be added.

Now the external images have been saved to the customized user image library of HMI, 
and can be called by users later.
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§ Case 3: How to call Image Library through controls? How to implement the transparent 
display of controls?

Requirements

Based on Case 2, this case describes how the multi-status indicator calls the image 
library created in Case 2, “screensaver cycle images”.

Purpose

Understand how controls call the image library, and learn how to implement transparent 
display of controls.

Pogramming Procedure

1.  How to Call Images in Image Library by the Multi-status Indicator?

1)	 From Menu bar, choose “Controls” > “Lamp” > “Word Lamp” to add a multi-status 
indicator control, which can be switched to display up to 256 statuses and images 
by changing data in the register.

2)	 Double-click this control to open “Multi-status indicator” dialog box, and then set 
“Read address” to LW0. As 5 images have been added into the image library 
“screensaver cycle images” to implement switchover among these 5 images, set 
“Status counts” to 5.

3)	 Call Image Library: Choose “Image” tab, click “Library” to open “Image Library 
Manager” dialog box, in which click “User image library” tab to choose library 
“screensaver cycle images”, and click “OK”.
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Now the image library calling has been successfully configured, and the 5 statuses in the 
multi-status indicator correspond to the 5 images in this image library respectively.

2. Add a multi-status setting control to implement cyclic display of the multi-status 
indicator.

1)	 From Menu bar, choose “Controls” > “Status” > “Set Word”, and set up relevant 
parameters as below. Preview the effect through offline simulation.
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3. How to implement transparent display of controls?

On “Image” tab of “Multi-status indicator” dialog box, uncheck “Use image library” to 
implement transparent display of the control.

 

After the option is unchecked:

See below comparison of the same control with “Use image library” checked and 
unchecked respectively (transparent disposal):
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§ 2 Direct Window and Indirect Window

§ Case 4: How to create a pop-up menu?

Requirements

Create a pop-up menu by using the direct window

Purpose

Master the definition and usage of the direct window, and through this case, further 
explore functions that can be implemented with the direct window.

Programming Procedure

1. Direct window introduction

Direct window control shows/hides the window based on a bit status of HMI or PLC. 
When HMI detects that the bit status is ON, the predefined window appears at the 
position where the “direct window” control is, with the same size as this control.

2. Implementation steps for a pop-up window:

●● Create 4 basic windows, named “dialog 1”, “dialog 2”, “dialog 3” and “dialog 4”.

●● Add a direct window in “Public Window”: from Menu bar, choose “Controls” > “Direct 
Window”, and then set its size and position as needed.

●● In “Public Window”, add a “Bit status transfer switch” control with an address of M0 
to show/hide the direct window, which is the “menu” button in the figure above.
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»  Create a new basic window, and adjust it to the same size as the “direct window” 
control.

»  In this window, add 4 function keys to call the other windows.
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»  Under simulation mode, click “menu” button to show/hide the pop-up menu.
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§ Case 5: How to make a help document for troubleshooting the AC drive?

Requirements

Make a help document for troubleshooting the AC drive with the indirect window.

Purpose

Understand the definition and usage of the indirect window; through this case, further 
explore functions that can be implemented with the indirect window.

Programming Procedure

1. Indirect window introduction

Indirect window control determines which window to pop up based on the data from a 
register of HMI or PLC. Like “Basic window” attribute in “PLC Control”, when data in 
the register is same as the number of a certain window, this window will appear at the 
position where the “indirect window” control is, with the same size as this control.

2. Implementation steps for making a help document with the indirect window:

1)	 Create a new basic window:

●● Add an “indirect window” control, for displaying relevant window contents, with an 
address of LW0.

●● Add an “Item list” control to control the number of the window to be displayed by 
“indirect window” of LW0.
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2)	 Create another new basic window named “ER02 fault”, and adjust it to the same 
size as the “indirect window” control.

3)	 Add relevant alarm information, fault reasons and solutions in this window.

4)	 As the troubleshooting windows have the same format, you can simply copy window 
3 to 8, and then modify window names and contents.
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5)	 Perform offline simulation, and click each fault code to display the corresponding 
fault reasons and solutions.

Overcurrent fault display

Overvoltage fault display
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§ 3 Multi-Language and Text Label Library

§ Case 6: How to implement multi-language switchover?

Requirements

Edit multi-language by using a text label library, and switch between different languages 
through the special flag bit of LW9134.

Purpose

●● Understand the convenience of using a text label library.

●● Learn how to use a text label library.

●● Learn how to switch between different languages.

Programming Procedure

1. How to create a new text label library?

1)	 Double-click “Project management” > “Text label library” on the left side of the 
software, as shown below:

2)	 Right-click the position pointed by the arrow, and choose “Add Text Label Item”.
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3)	 After “Add a Text Label” dialog box pops up, enter a “Label name” as required to 
distinguish among different labels. In this case, it is named “motor start”.

4)	 Click “OK” button to open the following dialog box, in which you can edit 8 
languages and multiple statuses.

The text label in this case is named “motor start”, which contains two statuses: “motor 
start” and “motor stop”. Four languages can be switched to show statuses: when 
“Status No.” is 0, type “ 电机启动”, “Motor start”, “馬達發動” and “Démarrage 
du moteur” respectively, as shown below:

When “Status No.” is 1, type “电机停止”, “motor stop”, “電機停止” and “L’arrêt 
du moteur” respectively, as shown below:
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Click “OK”, and the text label library for motor start/stop button has been successfully 
created.

2. Use a switch button to call created text labels.

1)	 Create a “Bit status transfer switch” control, double-click it to open “Bit status 
transfer switch” dialog box, and then set the “Read address” on “General” tab to 
M100.

2)	 On “Label Attributes” tab, check “Use text library”, and in “Label” drop-down list, 
choose “motor start”.
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3)	 Now the text label library calling has been successfully configured.

3. Multi-language switchover:

1)	 The system register of LW9134 is needed for language switchover, with a valid 
range of 0 to 7, corresponding to 8 languages (“Language 1 to Language 8”) in Text 
Label; That is: When LW9134=0, the content of “Language 1” in “Text Label Library” 
will be displayed, when LW9134=1, the content of “Language 2” in “Text Label 
Library” will be displayed, and so on. If the value of LW9134 exceeds the range of 0 
to 7, the content finally displayed shall prevail.

2)	 Add a multi-status setting control (“Controls” > “Status” > “Set Word”), choose 
LW9134 for “Addr. type”, and check “System register”.

3)	 On “General Attributes” tab, choose “Write in constant” for “Mode”, and enter 0 for 
“Write in constant”, as shown below:

4)	 Then on “Label Attributes” tab, check “Use text label” (this button does not use the 
text label library), and enter “English” in “Contents” field, as shown below:
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5)	 Now the English button has been completed successfully, as shown below:

6)	 Repeat Step 2 to 4 for the other three language buttons, enter 1, 2 and 3 for “Write 
in constant” respectively, and enter corresponding language text in “Contents” fields. 
Details will be omitted here, and the result is as shown below:

7)	 Now the text label library and multi-language display have been completed 
successfully. 

Click the button as needed to display corresponding language, as shown below:	
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Multi-language must be implemented through the text label library. Before project design, 
please decide whether multi-language display is needed in order to avoid effort in vain.
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§ 4 Screensaver Function

§ Case 7: How to implement screensaver - approach 1

Requirements

Create two new windows. If either of them has not been operated for 10s, the current 
window will switch to the screensaver window; if it is operated within 10s, re-count the 
time.

 Case Key Points

●● In “Public Window”, add a “Bit status transfer switch” control, with the same size as 
the public window, to determine whether there is any operation performed to the 
window within a specified time. Re-count the time if there is, and enter screensaver 
window if there isn’t.

●● In “Public Window”, add a “multi-status setting” control for recording no-operation 
time of the current window.

●● How to enter the screensaver window after a specified no-operation time?

●● Here, the address of a switch window defined through “PLC control table” > “Switch 
basic window” is used. Once the specified no-operation time is reached, the number 
of the screensaver window will be written into the address so as to switch the 
current window to the corresponding screensaver window.

Programming Procedure

1. Case: If the HMI window has no operation for 10s, it will switch to the 
screensaver window

1)	 Create a new HMI project, named “Screensaver case project”.

2)	 Click “Project management” >”Page” and then right-click it to choose “Add Page” 
to add a window, named “window 1”. Repeat the steps to create another window, 
named “window 2”.
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3)	 Add an image control for these two windows respectively: From Menu bar, choose 
“Draw” > “ Image” control, and then import an image from a library or a file. In this 
case, an image will be imported from a file (the image must be in the same path as 
this project, for successful importing). This step aims to distinguish window 1 from 
window 2.

4)	 Add a “Function key” control for each of the two windows to switch between them, 
and choose “Basic window” on “General” tab.

5)	 The results are shown in the following “Window 1” and “Window 2”. The two 
windows can be switched through window switching buttons.

Window 1
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Window 2

6)	 Add a user image library named “screensaver cycle images”.

●● From Menu bar, choose “Media Lib” > “Open Image Library” to open “Image Library 
Manager” dialog box.

●● In “Image Library Manager” dialog box, click “User image library” > “Add” to open 
the “Add an image library” dialog box and then enter the name of the new image 
library, “screensaver cycle images”.

	

●● Click “Add image” at the lower right corner to open “Add an Image” dialog box, 
click “Browse...” to locate the image folder, choose the image to be used for the 
screensaver window, and then click “Add”. Here, 5 images will be added.
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●● Click “Project management”>”Page”, and then right-click it to choose “Add Page” to 
add a screensaver window. Set “Page No.” to 3, and then add three controls to this 
window:

7)	 Multi-status indicator control: It is used to display 5 images of the screensaver 
window.

●● From Menu bar, choose “Controls” > “Lamp” > “Word Lamp” to add a multi-status 
indicator control.

●● Double-click the “multi-status indicator” control to open “Multi-status indicator” 
dialog box. On “General” tab of the dialog box, set “Read addr.” to LW0, and “Status 
counts” to 5, which means to switch among 5 images.

  

●●  Choose “Image” tab, click “Library” to open “Image Library Manager” dialog box in 
which click “User image library” tab to choose library “screensaver cycle images”, 
and then click “OK”.
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8)	 Multi-status setting control: For automatic switching statuses of the user multi-status 
indicator.

●● Add a multi-status setting control: From Menu bar, choose “Controls” > “Status” > 
“Set Word” to add the control. Double click it to open the relevant dialog box for 
parameter setting to switch statuses of a multi-status indicator. Set “Attributes” on 
“General attributes” tab to “Cycle (0—max. value --0). Here, the range is set to 0 to 
5 to switch among the 5 images, and “Write address” is set to LW0, same as that of 
the multi-status indicator.

●● On “Image” tab, uncheck “Use image library” to transparently display the button, 
which is only used to control the cyclic display of the “multi-status indicator” and 
thus can be hidden.
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9)	 Function key control: It is used to switch to the last window before entering the 
screensaver window to continue operations.

●● Add a function key: From Menu bar, choose “Controls” > “Function Key” to add 
the control. Double click it to open the relevant dialog box, and on “General” tab 
choose “Return to the previous window” so as to return to the last window before 
entering screensaver window. The size of the function key is set to the same as the 
screensaver window, so that you can click anywhere on the screen to go back.

10)	 Open “Public Window” to add three controls.

●● Multi-status setting control: It is used to count no-operation time:

From Menu bar, choose “Controls” > “Status” > “Set Word” to add the control. 
Double click in to open the relevant dialog box, and on “General Attributes” tab, set 
“Mode” to “Cycle decrease (from high to low...)” and “Write addr.” to LW1; “Max. 
value” is to set the no-operation time before entering screensaver window, and here 
it is set to 10s.
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●●  Bit status transfer switch control: It is used to determine whether there is any 
operation performed to the window.

 From Menu bar, choose “Controls” > “Switch” > “Bit Switch” to add the control. 
Adjust it to the same size as the public window. Double click the control to open the 
relevant dialog box to set “Read addr.” to LB0, and uncheck “Use image library” on 
“Image” tab to transparently display this button.

This switch is used to determine whether there is any operation performed to HMI 
window. When this button is triggered, macro instructions will be executed, and LW1 
will be re-counted to ensure that the current window will switch to the screensaver 
window only after 10s of no-operation.

LB0 changing either from OFF to ON or from ON to OFF will reset LW1 to 10 to re-
count time.

●● PLC control table can be used to add a “Switch basic window” object.

Add a PLC control table: Click “Project management” > “PLC control table” to add 
the table. Open the “PLC control” dialog box to choose “Switch basic window” 
as the control type and set “Control addr.” to LW10, which is for switching to the 
screensaver window after 10s of no-operation.
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●● Add a “Cycle transfer switch” control to determine whether to enter the screensaver 
window.

From Menu bar, choose “Controls” > “Status” > “Set Bit” > “Cycle Transfer Switch” 
to add the control, which is used to determine whether the counting time is equal to 
1 in real-time. If counting time =1, the current window will switch to the screensaver 
window. This macro instruction is called through the PLC control table.

2. Macro instruction description:

1)	 Define a variable of screen_time to store the current value of LW1.

2)	 Judge the value of LW1 in real time. If the value is 1, it indicates that there has been 
no operation for 10s and the current window will switch to the screensaver window.
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§ Case 8: How to implement screensaver - approach 2

Requirements

Create two new windows. If either of them has not been operated for 10s, the current 
window will switch to the screensaver window; if it is operated within 10s, re-count the 
time.

Case Key Points

●● Window 1, window 2 and the screensaver window in this case are the same as 
those in “Case 7: How to implement screensaver approach 1”, and will not be 
described here again.

●● What’s different is that a “multi-status setting control” is added to every window in 
this case; for every window other than the public window, in respective “Multi-status 
setting” dialog box, set “Mode” to “Set when window is opened”, enter 0 in “Write in 
constant” field, and then set “Write addr.” to the address of “Switch basic window” in 
“PLC control table”; and for the public window, set “Mode” to “Cycle decrease” in the 
relevant “Multi-status setting” dialog box.

Programming Procedure

1. Case: If the HMI window has no operation for 10s, it will switch to the 
screensaver window.

1)	 Please refer to “Case 7: How to implement screensaver approach 1” to create 
Window 1, Window 2 and the screensaver window.

2)	 Click “Project management” > “PLC control table” to open the “PLC control” dialog 
box. In this box, change “Control type” to “Switch basic window” and set “Control 
addr.” to LW1.
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3)	 Add a “multi-status setting” control to Window 1, Window 2 and the screensaver 
window respectively. Double-click the control to open its dialog box. Under 
“Attributes” on the “General attributes” tab of the dialog box, set “Mode” to “Set 
when window is opened”, enter 0 in “Write in constant” field, and set “Write addr.” to 
the address of “Switch basic window” in “PLC control table” (LW1). Here LW1 is set 
to 0 for two purposes.

●● Purpose 1: The minimum window No. is 1, and therefore when LW1 is set to 0, 
window switching will not be conducted.

●● Purpose 2: The “multi-status setting” control in the public window with a mode of 
“Cycle decrease” will switch the window circularly once the preset maximum value 
is decreased progressively to the minimum value.

4)	 Public window: From Menu bar, choose “Controls” > “Status” > “Set Word” to add 
the control, and then double-click it to open “Multi-status setting” dialog box. On its 
“General Attributes” tab, set “Mode” to “Cycle decrease (from high to low...)”, and 
“Write addr.” to LW1.
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2. Case summary:

1)	 This case combines the function of “multi-status setting” control with “Switch basic 
window” of “PLC control table” to implement the screensaver function.

2)	 The screensaver window No. in this case must be the No. of the last window in this 
project, so as not to switch to other windows while counting.

3)	 Set LW10, the control address for “Switch basic window”, to 3 (screensaver window 
No.), so that when time counts down to 3, the current window will switch to the 
screensaver window.
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§ 5 Animation, XY Curve and Dynamic Line Drawing

§ Case 9: How to use animation controls?

Control Description

Animation controls: Dynamically show the operational processes of equipment through 
simulation, to deliver more intuitive and vivid results.

The animation controls in HMI need predefined motion profiles. By changing data in the 
register, you can control the status of controls as well as make sure they are following 
the motion profiles.

Requirements

●● Create a text string of “Welcome to use Inovance HMI!” appearing one word by one 
word.

●● Pre-define a motion profile and make sure it is followed.

Case Key Points

●● Through this case, learn to control the animation controls by data in register.

●● Through this case, learn to control the animation controls by clock.

Programming Procedure

1. Create a text string of “Welcome to use Inovance HMI!” appearing one word by 
one word.

1)	 Add an animation control: From Menu bar, choose “Controls” > “Curve&Graph” > 
“Animation” to add an animation control to the window.

2)	 Set up the animation control: Double-click the control to open “Animation” dialog 
box, as shown below:
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3)	 For “Animation position control mode”, choose “By data in register”, so that the 
status and position of the control will change with the data in register.

4)	 See the table below for reading addresses for control positions. “Address” in the 
table indicates the address of a register, for example, the address of register [LW100] 
is 100.

5)	 The reading address in this case is LW0, and LW0 stands for the control’s status. 
LW1 stands for the control’s position.

●●  Animated object status counts: It depends on LW0 above. As “Welcome to use 
Inovance HMI!” includes totally 6 words, therefore set “Animated object status 
counts” to 6.

●● On “Label Attributes” tab, input relevant content for each status.

●● Status 0: Type “welcome” in “Contents” field.

●● Status 1: Type “welcome to” in “Contents” field.
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●● Follow this all the way to status 9.

6)	 Click “Text attribute setting” to set Font, Color and Size, and click “Each status” to 
deliver a unified style for the contents of all 6 status.

  

7)	 Add a multi-status setting control to HMI programming window, and change the 
status of LW0 from 1 to 6 to show words of the text string one by one.
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8)	 Now the case for the text string appearing one word by one word has been 

successfully completed, and you can perform offline simulation to preview it.

2. Move along the predefined motion profile.

1)	 Add an animation control: From Menu bar, choose “Controls” > “Animation” to add 
an animation control to the window, set 10 points according to the desired path, and 
then add description for each point.

2)	 Set up the animation control: Double-click the control to open “Animation” dialog 
box, as shown below:
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3)	 For “Animation position control mode”, choose “By clock”, so that the status and 
position of the control will change with time.

4)	 If an animation position is incorrect, you can make fine-tuning under “Control point 
position” on “Profile” tab, as shown below:

Above are two animation control instances, you can perform offline simulation to preview 
the results.
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§ Case 10: How to draw a rectangle and a square by using XY curves?

Requirements

XY curve control is used to draw figures by connecting multiple coordinate points. This 
case shows how to draw a rectangle and a square by using XY curve control.

Case Key Points

1.	 Through this case, learn the meaning of each control address of a XY curve control.

2.	 Through this case, learn how to display multiple curve figures (max. 16 pcs) 
simultaneously with one XY curve control.

3.	 XY curve is drawn by connecting all coordinate points.

Programming Procedure

1. Case: To draw a square and a rectangle:

1)	 Add an XY curve control: From Menu bar, choose “Controls” > “Curve&Graph” > “XY 
Plot” to add an XY curve control to the window.

2)	 Set up the XY curve control: Double-click the XY curve control to open “XY curve” 
dialog box, as shown below:
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3)	 Number of channels: As we are going to display a square and a rectangle in this XY 
curve control, therefore, set “Number of channels” to 2.

4)	 Control address: It is used to display/clear the figure; in this case, it is LW0.

●● The value of the control address is 1: Display XY curve, and the original figure 
remains.

●● The value of the control address is 2: Clear the current XY curve.

●● The value of the control address is 3: Clear the displayed XY curve and replace it 
with a new XY curve.

●● The value of the control address is 4: Clear all previous instructions.

5)	 Data number address: It is used to set the number of coordinate points forming the 
XY curve figure. The range of “Number of channels” is (1 to 1023), and Data number 
address = Control address + 1, that is LW1.

6)	 Set the data address of each coordinate point in the rectangle: Choose Channel 0, 
set “Read addr.” to LW10 (thus LW10=X0, LW11=Y0; LW12=X1, LW13=Y1 and so 
on), and then set the relevant upper/lower limit properly.
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7)	 Set the data address of each coordinate point in the square: Choose Channel 1, 
and set “Read addr.” to LW30.

8)	 When creating a figure with an equal proportion, please make sure the XY curve 
control has the same width and height, otherwise, it may lead to an incorrect 
proportion, as shown below. In this case, the width and height are both 309.

9)	 Add “Control addr.”, “Data number addr.” (number of coordinate points) and XY 
coordinate addresses for XY curve control on HMI window. The address of “draw 
curves” button in the following figure is the control address for setting constant, and 
in this case, it is set to 3. Click “draw curves” button to clear the previous figure, 
draw a new figure and compile it. See below the offline simulation:
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§ Case 11: How to draw an equilateral triangle with the Dynamic Line Drawing control?

Requirements

The Dynamic Line Drawing control is used to draw figures through lengths and angles. 
Normally, it is applicable to the processing of work pieces with certain shapes. You can 
check through the simulation by this control whether the shape to be processed is what 
you expect. This case aims to draw an equilateral triangle with a side length of 200mm.

Case Key Points

1.	 Understand the definition of dynamic line drawing addresses.

2.	 Dynamic line drawing aims to draw figures through lengths between points, as well 
as relevant angles.

Programming Procedure

1. To draw an equilateral triangle

1)	 To add a dynamic line drawing control: Choose “Controls” > “Curve&Graph” > 
“Dynamic Line” from Menu bar, and add a dynamic line drawing control on the page.

2)	 To set attributes of dynamic line drawing: Double-click the control to open “Dynamic 
line drawing” dialog box to set relevant attributes, as shown below:

3)	 You can set “Color”, “Line type” and “Line width” under “Line parameters”. In this 
case, we will adopt the default values.

4)	 Line length display: line length display can be enabled or disabled. When the display 
is enabled, relevant font color, font size and display format can be set accordingly.

5)	 Curve type: You can choose the single-direction curve or the bi-direction curve. As 
an equilateral triangle is a figure, choose the single-direction curve here.



 Section 5 Animation, XY Curve and Dynamic Line Drawing                    

- 44 -

5

6)	 Scale: The length of a drawn line equals to the value of the line length register 
times this scale. As the line length register is variable, for an overlong line, scaling 
adjustment will be done during the drawing with this control, to maximumly keep the 
whole figure within the profile of the control.

7)	 Number of lines: The number of lines to be drawn. The maximum is 128. In this 
case, it is 3.

8)	 Start point coordinate: The initial address of the register of the dynamic line drawing 
control. All the registers used in this case are 16 bit registers. Starting from the 
initial address, the first register keeps the coordinate of the start point x, the second 
register keeps the coordinate of the start point y. The third register keeps the length 
of the first line, and the fourth register keeps the angle of the first line relative to 
the horizontal direction. From the fifth register, every two registers represent a line 
segment, which contains one length register and one clockwise angle register of a 
line to the previous one.

Note For the dynamic line drawing control, all angles are calculated in a 
clockwise manner.

9)	 In this case, the address of the start point coordinate is LW0, therefore, other 
addresses are as follows:

●● LW0 is the start point X coordinate, LW1 is the start point Y coordinate.

●● LW2 is the length of the first line, LW3 is the angle of the first line relative to the 
horizontal direction.

●● LW4 is the length of the second line, LW5 is the clockwise angle relative to the first 
line.

●● LW6 is the length of the second line, LW7 is the clockwise angle relative to the first 
line.

10)	 The offline simulation is shown as follows:

2. Draw a bilaterally symmetric figure

Note The curve type is bi-direction.
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The address of a bi-direction curve is defined as follows: Draw a bi-direction curve along 
the clockwise or counterclockwise direction starting from the start point coordinate.  As to 
the clockwise & counterclockwise direction mentioned here: Extend the end of a line and 
then draw an angle along the clockwise or counterclockwise direction.

1)	 Clockwise addresses are corresponding to: Start point (X: LW0, Y: LW1)

●● Data 1 (LW20, LW21)Data 2 (LW18, LW19)

●● Data 3 (LW16, LW17)

●● Data 4 (LW14, LW15)

●● Data 5 (LW12, LW13)

2)	 Counterclockwise addresses are corresponding to: Start point (X: LW22, LW23)

●● Data 1 (LW32, LW33)

●● Data 2 (LW30, LW31)

●● Data 3 (LW28, LW29)

●● Data 4 (LW26, LW27)

●● Data 5 (W24, LW25)

Remark:

1)	 Start point: For both single-direction cure and bi-direction curve, the start point plays 
a minor role, as relevant coordinate point will be re-calculated according to the input 
length and angle.

2)	 Make sure the number of registers match that of lines. The relationship between 
them: Single-direction curve: Number of registers = (number of lines +1)*2; Bi-
direction curve: Number of registers = (number of lines +1)*4.

The offline simulation is shown as follows:

1
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§ 6 Recipe

§ Case 12: How to implement the recipe function?

Definition of Recipe

During the daily production, when a machine is used to produce different products, 
different parameters need to be set. For example, when a cutting machine is used to cut 
an A type steel plate, the length is set to 1000mm and the width is set to 1000mm; when 
it is used to cut a B type steel plate, the length is set to 2000mm and the width is set to 
1500mm. Then these two sets of data can be considered as two sets of “recipe” data.

For example: If a recipe contains 100 data, and we need 20 recipes, there are 
100*20=2000 addresses available. If an index register is introduced, even though we still 
need 2000 addresses, it is only necessary to set 100 addresses plus an index register, 
which greatly reduces programming time and the number of images.

Required Controls

1. Data Transfer By Trigger

“Data Transfer By Trigger” means when this control is triggered, it will conduct data 
transfer from a continuous register at a designated position to one at another designated 
position. The data will be transmitted in word format.

2. Index register

An “Index register” is an indexed addressing register, with which, addresses that a control 
reads or writes can be modified online by changing the data in this register without 
changing device addresses. In this way, data transfer or exchange between addresses of 
different zones can be achieved.

In a word, once an index register is applied, the address of the device type in use 
depends on the set constant address + the value in the chosen index register.

Inovance HMI totally provides 32 index registers, of which 16 16-bit registers have the 
addresses ranging from LW9200 to LW9215, and 16 32-bit registers have the addresses 
ranging from LW9230 to LW9260.

An Example of Index Register

See the example below for a better understanding of the index register:

1)	 Step 1: Create a window as shown below:
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2)	 Step 2: Set the control attributes.

●● “Index register” is not checked, and the read address is its own address [LW100] 
.

 /  and  are in the same situation, all with unchecked “Index 
register” option. Now the read address is still its own address [LW110]/[LW120].

When “Index register” option is checked and INDEX0 is chosen for “Index”, the read 
address now is [LW(100 +INDEX 0)] , in which INDEX 0 represents data in 
[LW9200].

“Index register” is not checked, and the read address now is [LW9200].

3)	 Step 3: Save, compile and offline simulate.

The following figure shows that  now is 0, that is, data in [LW9200] is0, and thus 
reading [LW100+INDEX0] is equivalent to reading [LW100].
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Now if set content of  to 20, then reading LW(100+ index register 0) is equivalent 
to reading LW120.

Now back to Topic “How to implement the recipe function”---->

Use a steel plate cutting machine together with Inovance PLC to cut steel plates of five 
types.

Steel plate type Length (mm) Width (mm)
A type steel plate 1000 1000
B type steel plate 2000 1500
C type steel plate 2000 2000
D type steel plate 3000 3000
E type steel plate 4000 3500

1)	 Create new recipe data:

●● From the left side of the programming software, click “Project management” > 
“Recipe” > “Add Recipe”, as shown below:



                                                                                                                                                                     Section 6 Recipe

- 49 -

6

Name the recipe as “steel plate cutting machine”. As we are going to cut 5 types of steel 
plates and each of them contains two attributes, “Length” and “Width”, two fields need 
to be added. Enter 10 addresses (RW0 to RW9) for “Save addr.”, and then enter initial 
values for processing of steel plates, as shown below:

(As recipe data need retentive at power failure, retention addresses are all RW registers 
which are retentive at power failure)

2)	 Set the window content:

Add number input controls to set “length” and “width” of the steel plate, with addresses of 
RW0 and RW1, and then check “Index register” and choose “INDEX 0”, as shown below:
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A type steel plate has corresponding addresses of RW0 and RW1, B type steel plate has 
corresponding addresses of RW2 and RW3……E type steel plate has corresponding 
addresses of RW8 and RW9.

3)	 Add an index register to switch among different recipes.

Once an index register is applied, the current steel plate type can be changed simply 
by changing the value in the index register. If the current value in the index register is 2, 
the current address =RW0+2=RW2  RW1+2=RW3, which are addresses for B type steel 
plate, and the like. For this case, a “Drop-down list” is used for switching among different 
steel plate types, the system register is chosen for the control address, and LW9200 is 
the index register 0 address.

Click “Status Setting” tab to set status as shown below:

Now the 5 recipes all have their own addresses. Form Menu bar, click “Controls” > “Button” 
> “Data Transfer By Trigger” to add a control which can transmit current data of steel 
plate types to PLC for production.



                                                                                                                                                                     Section 6 Recipe

- 51 -

6

●● While transmitting HMI data to PLC, the source address is the HMI address. The 
block counts is the number of words in a recipe. If the recipe address is 32-bit, the 
block counts = the number of attributes in each recipe *2. For example, in this case, 
each recipe contains 2 attributes, and each attribute is a word data, so here the 
block counts is 2. If every attribute in this case is a double word data that is 32-bit 
data, the block counts is 4.

●● While transmitting data in PLC to HMI, the source address is the PLC address, and 
the target address is the HMI address. At this time, check “Index register” checkbox 
for the target address.

4)	  Now, the configuration of recipe data has been completed. Offline simulation is 
shown below:

»  For example, to process a B type steel plate, choose B type steel plate:

»  Click “download” to transmit the B type steel plate data to PLC, as shown below:
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§ 7 Communication

§ Case 13: How to implement HMI monitor protocol communication between HMI and 
Inovance PLC?

Requirements

Use Inovance HMI to implement HMI monitor protocol communication through COM0/
COM1/COM2 port of Inovance PLC.

Purpose

1.	 Learn how to set communication parameters when communicating under the HMI 
monitor protocol with Inovance PLC.

2.	 Learn how to conduct wiring when communicating under the HMI monitor protocol 
with Inovance PLC.

Descriptions

1.	 The HMI monitor protocol between Inovance HMI and Inovance PLC can only 
support one to one communication. If an HMI need to communicate with three PLCs 
by the HMI monitor protocol, it is required to use three communication ports of HMI 
to communicate with three PLC COM ports respectively.

2.	 Inovance PLC H1U has two communication ports, COM0 and COM1, and H2U has 
three communication ports, COM0, COM1 and COM2. All can implement the HMI 
monitor protocol.

3.	 Inovance PLC’s HMI monitor protocol has a fixed communication format, 9600, 7, E, 
1. The communication fails if the communication format is wrong.

4.	 The communication protocol and communication format of Inovance PLC can be set 
in system parameters or by using a special register.

5.	 When using HMI to communicate with Inovance PLC, the communication mode 
must be correctly set:

1)	 If it is RS232 communication, the communication mode is RS232.

2)	 If it is RS485 communication, the communication mode is RS485-2W.

3)	 If it is RS422 communication, the communication mode is RS485-4W.

6.    Communication cables must be correctly selected and made. See below for details.

Communication Cable Selection and Pin Definition

1. HMI DB9 female and male pins are defined as follows:

1)	 DB9 female pins: Communication ports including COM1[RS485 2/4W], COM3 
[RS485], and COM3 [RS232] on the back of the housing, which are used to connect 
controllers with RS485, RS422, and RS232 communication ports (COM1[RS485] 
4-wire is COM1 [RS422]). Refer to the table below for the pins arrangement.
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Pin No.

Signal
DB9 Female Pins 

Arrangement
COM1 

[RS485] 
2-wire

COM1 [RS422]
COM3 

[RS485]
COM3 [RS232]/

COM2 [RS232]※

1 RS485- RX- (Receive negative)

2 RS485+ RX+ (Receive positive)

3 TX- (Transmit negative)  
4 TX+ (Transmit positive)
5 GND (Signal ground)

6 RS485-

7 TXD (Transmit)

8 RXD (Receive)

9 RS485+

 ※1. Model IT5043T uses COM2 [RS232], and other models use COM3 [RS232].

※2. Serial ports can be used to connect serial port printers. Please refer to the 
commissioning software help for detailed setting.

2)	 DB9 male pins: COM1 [RS232]/COM2 [RS232]. This port is used to connect 
controllers with RS232 communication port. Refer to the table below for the pins 
arrangement.

Pin No.
Signal

DB9 Male Pins Arrangement
COM1 [RS232] COM2 [RS232]

1

2 RXD (Receive data)

3 TXD (Transmit data)

4 TXD (Transmit data)

5 GND (Signal ground)

6 RXD (Receive data)

7
RTS (Ready for 

transmit)

8
CTS (Clear transmit 

input)

9

2. PLC port introduction

1)	 Inovance H2U has three communication ports: COM0[RS422], COM1[RS485] and 
COM2[RS485], as shown below:
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2)	 Inovance H1U has two communication ports: COM0[RS422], and COM1[RS485], as 
shown below:

3)	 Based on the above figures, we can choose proper communication ports for 
Inovance HMI and Inovance PLC:

» 1 Use the HMI COM1 RS422 interface to communicate with Inovance PLC COM0 port. 
Inovance will provide the relevant cable (Model IT5-H2U-CAB).

» 2 Use HMI COM1 or COM3 RS485 interface to communicate with Inovance PLC COM1 
or COM2 port. Inovance will not provide the relevant cable, but customers can make one 
by themselves based on the pin definition.

» 3 Use the HMI COM1 RS232 interface to communicate with Inovance PLC COM0 port. 
As the PLC COM0 port is for RS422 interface, it is necessary to use a RS232 to RS422 
converter. The Inovance download cable H2U-232-CAB is a 232 to 422 conversion cable, 
which can be used for Inovance HMI COM1 to PLC COM0 communication.

» 4 Use HMI COM1/COM2/COM3 RS232 interface to communicate with Inovance PLC 
COM1 port. In such a case, use a RS232 to 485 converter, or the expansion card H2U-
232-BD of Inovance PLC to convert PLC COM1 port into RS232 interface.

»  Above all, Inovance HMI and Inovance PLC can communicate through various 
methods, which can be selected according to your specific requirements.
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Programming Procedure

1. HMI communication configuration

1)	  Add a PLC device: From “Project management” > “Device” > “Local”, right-click 
corresponding COM port, and choose “Add Device” from the shortcut menu.

2)	 In the”Device” dialog box that is displayed for “Device model” field, select H2U from 
the “Device model” drop-down list. If a PLC device from other manufacturers is 
used, choose the corresponding PLC model.

3)	 Connect port: It is the number of the HMI port used to connect with the PLC.

4)	 Preset station No.: It is the station number of the connected device, not the station 
number of the HMI.

5)	 Click “Set” button in the above figure to open the following dialog box, in which:

»  If HMI COM1 RS422 interface is used to communicate with PLC COM0 port, the 
communication mode is RS485-4W.

»  If HMI COM1 RS232 interface is used to communicate with Inovance PLC, the 
communication mode is RS232.

»  If HMI COM1 RS485 interface is used to communicate with Inovance PLC, the 
communication mode is RS485-2W.

»  The fixed communication format is 9600. 7. E. 1.
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6)	 On the HMI window, add control buttons Y0 to Y7, as well as status indicators Y0 to 
Y7, and then establish the communication.

2. PLC communication parameter setting

1)	 When COM0 is used, the settings are as follows:

»  Start PLC programming software and double-click “Communication Config” in “Project 
management” to open “COM Config” dialog box. On “COM0 Config” tab, choose “HMI 
monitor protocol”, with the fixed protocol configuration of 9600, 7, E, 1 (by default, no 
need to modify the configuration), as shown below:

2)	 When COM1 or COM2 is used, the settings are as follows:

»  Note: As COM1 and COM2 are both RS485 interface, they have the same settings 
except for the special registers related to communication. Here we will introduce their 
settings together. Use the same way mentioned above for COM0 to open “COM Config” 
dialog box, and set relevant parameters as shown below:
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3)	 Method for setting communication parameters through special registers.

PLC COM Ports
Communication Protocol (HMI 

Monitor Protocol)
Communication Format 

(9600.7.E.1)
PLC Station 

COM0 port D8116=H1 D8110=H86 D8111
COM1 port D8126=H1 D8120=H86 D8121
COM1 port D8266=H1 D8260=H86 D8261

»  COM0 port settings

»  COM1 port settings

»  COM2 port settings
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§ Case 14: How to implement Modbus protocol communication between HMI and 
Inovance PLC?

Requirements

Use Inovance HMI to implement Modbus protocol communication with COM0/COM1/
COM2 port of Inovance PLC.

Purpose

1.	 Learn how to set communication parameters when communicating under the 
Modbus protocol with Inovance PLC.

2.	 Learn how to conduct wiring when communicating under the Modbus protocol with 
Inovance PLC.

Descriptions

1.	 The Modbus protocol supports one-to-many communication between Inovance HMI 
and Inovance PLC. HMI serves as the Modbus master station, and PLC works as 
the Modbus slave station.

2.	 Inovance PLC H1U has two communication ports, COM0 and COM1, and H2U 
has three communication ports, COM0, COM1 and COM2, all of which support the 
Modbus slave station protocol.

3.	 Inovance HMI designed a specialized drive, H2UModbus _RTU, for the Modbus 
communication with Inovance PLC. The advantage of this drive is that it converts 
the Modbus addresses of the PLC into the PLC internal addresses, so that the 
Modbus addresses of the PLC do not need to be matched one by one.

4.	 4	For example, Y0 has a Modbus address of FC00. When the specialized drive is 
used, the address will be Y0, and there is no need to find the corresponding Modbus 
address of Y0, FC00.

5.	 The communication protocol and communication format of Inovance PLC can be set 
through system parameters or by using a special register.

6.	 When using HMI to communicate with Inovance PLC, the communication mode 
must be correctly set:

1)	 If it is RS232 communication, the communication mode is RS232.

2)	 If it is RS485 communication, the communication mode is RS485-2W.

3)	 If it is RS422 communication, the communication mode is RS485-4W.

4.	 	 Communication cables must be correctly selected and made. See below for details.
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Communication Cable Selection and Pin Definition

1. HMI DB9 female and male pins are defined as follows:

1)	 DB9 female pins: Communication ports including COM1[RS485 2/4W], COM3 
[RS485] and COM3 [RS232] on the back of the housing, which are used to connect 
controllers with RS485, RS422 and RS232 communication ports (COM1[RS485] 
4-wire is COM1 [RS422]). Refer to the table below for the pins arrangement.

Pin 
No.

Signal
DB9 Female Pins 

Arrangement
COM1 

[RS485] 
2-wire

COM1 [RS422]
COM3 

[RS485]
COM3 [RS232]/

COM2 [RS232]※

1 RS485- RX- (Receive negative)

2 RS485+ RX+ (Receive positive)

3 TX- (Transmit negative)

4 TX+ (Transmit positive)

5 GND (Signal ground)

6 RS485-

7 TXD (Transmit)

8 RXD (Receive)

9 RS485+

※1. Model IT5043T uses COM2 [RS232], and other models use COM3 [RS232].

※2. Serial ports can be used to connect serial port printers. Please refer to the 
commissioning software help for detailed setting.

2)	 DB9 male pins: COM1 [RS232]/COM2 [RS232]. This port is used to connect 
controllers with RS232 communication port. Refer to the table below for the pins 
arrangement.

Pin No.
Signal

DB9 Male Pins Arrangement
COM1 [RS232] COM2 [RS232]

1
2 RXD (Receive data)
3 TXD (Transmit data)
4 TXD (Transmit data)
5 GND (Signal ground)
6 RXD (Receive data)
7 RTS (Ready for transmit)
8 CTS (Clear transmit input)

9
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2. PLC Port Introduction

1)	 Inovance H2U has three communication ports: COM0[RS422] COM1[RS485] and 
COM2[RS485], as shown below:

2)	 Inovance H1U has two communication ports: COM0[RS422], and COM1[RS485], as 
shown below:

3)	 Based on the above figures, we can choose proper Modbus communication ports 
for Inovance HMI and Inovance PLC:

»  Use HMI COM1 or RS485 interface of COM3 port to communicate with COM0 , 
COM1 or COM2 port of Inovance PLC. Inovance will not provide the relevant cable, but 
customers can make one by themselves based on the pin definition.

Programming Procedure

1. HMI communication configuration

1)	 Add a PLC device: From “Project management” > “Device” > “Local”, right-click 
corresponding COM port, and choose “Add Device” from the shortcut menu.
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2)	 In the “Device” dialog box that is displayed, for “Device model” field, select 
H2UModbus_RTU or Modbus_RTU from the “Device model” drop-down list. If a 
PLC device from other manufacturers is used, only choose Modbus_RTU.

3)	 Click “Set” to open “Communication Setting” dialog box (as this case requires to 
connect two PLCs, choose RS485_2w for “Comm. mode”):

	

4)	 When connecting the second PLC, right-click COM1 again, and repeat the above 
steps to add the second device.
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Note:

»  Change the “Device name” of the second device to “Modbus-Rtu1”, as shown below:

»  Make sure the communication modes of the two PLCs are both RS485_2w, and also 
make sure they have the same communication format settings.

»  Additional instructions: This case shows an example of using HMI COM1 port to 
connect two Inovance PLCs. The completed interface is shown below:

5)	 On the HMI window, add control buttons Y0 to Y7, as well as status indicators Y0 to 
Y7, and then establish the communication.
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»  Settings of communication addresses: When two PLCs are added, there will be two 
address types used to control different PLCs.

2. PLC communication parameter setting

1)	 When COM0 is used, the settings are as follows:

»  Start Inovance PLC programming software AutoShop, and double-click “Communication 
Config” in “Project management” to open “COM Config” dialog box. On “COM0 Config” 
tab, choose “Modbus-RTU Slave Site” for “Protocol”. The protocol configuration is 
consistent with that of HMI, as shown below:
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2)	 When COM1 or COM2 is used, the settings are as follows:

»Note: As COM1 and COM2 are both RS485 interface, they have the same settings 
except for the special registers related to communication. Here we will introduce their 
settings together. Use the same way mentioned above for COM0 to open “COM Config” 
dialog box, and set relevant parameters as shown below:

»Additional instructions: Method for setting communication parameters through special 
registers.

PLC COM Ports Communication Protocol (HMI 
Monitor Protocol)

Communication Format 
(9600.8.N.1)

PLC Station Num-
ber

COM0 port D8116=H2 D8110=H81 D8111
COM1 port D8126=H2 D8120=H81 D8121
COM1 port D8266=H2 D8260=H81 D8261
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»  COM0 port settings

»  COM1 port settings

»  COM2 port settings

3)	 Additional instructions:

»  The corresponding relation table of Inovance PLC Modbus addresses:

●● Coil addressing: Coil: It refers to bit variables, with only two status, 0 and 1. This 
PLC includes variables such as M, S, T, C, X, Y, etc.

Variable Name Initial Address Number of Coils Instruction

M0 to 3071 0 (0) 3072
M8000 to M8255 0×1F40 (8000) 256

S0 to S999 0×E000 (57344) 1000
T0 to T255 0×F000 (61440) 256
C0 to C255 0×F400 (62464) 256
X0 to X255 0×F800 (63488) 256
Y0 to Y255 0×FC00 (64512) 256
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●● Register address: Register: It refers to 16-bit or 32-bit variables. For this PLC, 16-bit 
variables include D, T, and C0 to 199; 32-bit variables include C200 to 255.

Variable Name Initial Address Number of Registers Instruction

D0 to D8255 0 (0) 8256
T0 to T255 0×F000 (61440) 256
C0 to C199 0×F400 (62464) 200
C200 to C255 0×F700 (63232) 56 32-bit registers

» Note: When MODBUS is used to visit 32-bit registers of C200 to C255, one register 
will be treated as two. One 32-bit register occupies space of two 16-bit registers. For 
example, if a user reads or writes four registers of C205 to C208, the MODBUS address 
is 0×F70A (0×F700+10), and the number of registers is 8 (4*2).

3. Introduction of MODBUS addresses corresponding to HMI:

InoTouch Editor software has multiple device types for the MODBUS protocol, including 
0x, 1x, 3x, 4x, 5x, 6x, as well as 4x_bit and 3x_bit, etc. The function codes supported by 
these device types under the MODBUS protocol are described below.

1)	 0x: It is a readable and writable device type, equivalent to operating the output point 
of the PLC. When it is in reading status, it gives a function code of 01H, while in 
writing status, it gives a function code of 05H.

2)	 1x: It is a read-only device type, equivalent to reading the input point of the PLC. 
When it is in reading status, it gives a function code of 02H.

3)	 3x: It is a read-only device type, equivalent to reading the analogue variable of the 
PLC. When it is reading data, it gives a function code of 04H.

4)	 4x: It is a readable and writable device type, equivalent to operating data registers 
of the PLC. When it is reading data, it gives a function code of 03H, and when it is 
writing data, it gives a function code of 10H.

5)	 5x: This device type has the same attributes as 4x. That is, function codes given 
by them while reading or writing data are exactly the same. What’s different is that, 
in the case of double bytes, for example, 32_bit unsigned data, when reading data 
with 5x and 4x, the position of high byte and low byte are reversed. For example, if 
4x device type reads 0x1234, 5x device type reads 0x3412.

6)	 6x: It is a readable and writable device type. When it is reading data, it also gives a 
function code of 03H. What’s different with 4x is that when it is writing data, it gives 
a function code of 06H, which means data for writing a single register.

7)	 3x_bit: The function codes supported by this device type are the same as 3x device 
type. What’s different is that, 3x reads data, while 3x_ bit reads the status of a 
certain bit in the data.

8)	 4x_bit: The function codes supported by this device type are the same as 4x device 
type. What’s different is that, 4x reads data, while 4x_ bit reads the status of a 
certain bit in the data.
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§ Case 15: How to implement QLink protocol communication between HMI and Inovance 
PLC?

Requirements

Use Inovance HMI to implement QLink protocol communication through COM0/COM1/
COM2 port of Inovance PLC.

Purpose

1.	 	 Learn how to set communication parameters when communicating with Inovance 
PLC under the QLink protocol.

2.	 	 Learn how to conduct wiring when communicating with Inovance PLC under the 
QLink protocol.

Descriptions

1.	 The QLink protocol is an additional function based on the MODBUS protocol, aiming 
to improve the efficiency of communication between HMI and H2U-xp to speed up 
the data refresh.

2.	 Software version requirement: HMI: V1.21 or later.	 H2U-XP: 24132 or later.

3.	 The QLink protocol communication between Inovance HMI and Inovance PLC only 
supports one-to-one communication. HMI serves as the master station, and PLC 
works as QLink slave station.

4.	 All Inovance PLC COM ports support the QLink slave station protocol.

Communication Cable Selection and Pin Definition

1. HMI DB9 Female and Male Pins Are Defined as Follows:

1)	 DB9 Female Pins: Communication ports including COM1[RS485 2/4W], COM3 
[RS485] and COM3 [RS232] on the back of the housing, which are used to connect 
controllers with RS485, RS422 and RS232 communication ports (COM1[RS485] 
4-wire is COM1 [RS422]). Refer to the table below for the pins arrangement.

Pin No.
Signal DB9 Female Pins

ArrangementCOM1[RS485] 2-Wire COM1 [RS422]
COM3 

[RS485]
COM3 [RS232]/

COM2 [RS232]※

1 RS485- RX- (Receive Negative)

2 RS485+ RX+ (Receive Positive)

3 TX- (Transmit Negative)

4 TX+ (Transmit Positive)

5 GND (Signal Ground)

6 RS485-

7 TXD (Transmit)

8 RXD (Receive)

9 RS485+

※1. Model IT5043T uses COM2 [RS232], and other models use COM3 [RS232].
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※2. Serial ports can be used to connect serial port printers. Please refer to the 
commissioning software help for detailed setting.

2)	 DB9 Male Pins: COM1 [RS232]/COM2 [RS232]. This port is used to connect 
controllers with RS232 communication port. Refer to the table below for the pins 
arrangement.

Pin No.
Signal

DB9 Male Pins Arrangement
COM1 [RS232] COM2 [RS232]

1

2 RXD (Receive Data)

3 TXD (Transmit Data)

4 TXD (Transmit Data)

5 GND (Signal Ground)

6 RXD (Receive Data)

7 RTS (Ready for Transmit)

8 CTS (Clear Transmit Input)

9

2. PLC Port Introduction

1)	 Inovance H2U has three communication ports: COM0[RS422], COM1[RS485] and 
COM2[RS485], as shown below:	

2)	 Inovance H1U has two communication ports: COM0[RS422], and COM1[RS485], as 
shown below:
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3)	 Based on the above figures, we can choose proper Modbus communication ports 
for Inovance HMI and Inovance PLC:

»  Use HMI COM1 or RS485 interface of COM3 port to communicate with COM1 or 
COM2 port of Inovance PLC. Inovance will not provide the relevant cable, but customers 
can make one by themselves based on the pin definition.

Programming Procedure

1. HMI Communication Parameter Setting

1)	 Add a PLC device: From “Project management” > “Device” > “Local”, choose 
corresponding COM port, and right-click “Add Device”.

2)	 In the “Device” dialog box that is displayed, for “Device model”, select “Inovance 
PLC QLink protocol” from the “Device model” drop-down list.
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3)	 Click “Set” button on the above figure to open the following dialog box, in which set 
the data format as desired, as shown below:

4)	 On the HMI window, add control buttons Y0 to Y7, as well as status indicators Y0 to 
Y7, and then establish the communication.

»  The address type is set as shown below:
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2. PLC Communication Parameter Setting

1)	 When COM0 is used, the settings are as follows:

 »  Start the PLC programming software Autoshop, and double-click “Communication 
Config” in “Project management” to open “COM Config” dialog box. On “COM0 Config” 
tab, choose “Modbus-RTU Slave Site” for “Protocol”. The protocol configuration is 
consistent with that of HMI, as shown below:

2)	 When COM1 or COM2 is used, the settings are as follows:

»Note: As COM1 and COM2 are both RS485 interfaces, they have the same settings 
except for the special registers related to communication. Here we will introduce their 
settings together. Use the same way mentioned above for COM0 to open “COM Config” 
dialog box, and set relevant parameters as shown below:
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3)	 Additional Instructions: Method for setting communication parameters through 
special registers.

COM Ports of PLC
Communication Protocol 
(HMI monitor protocol)

Communication Format 
(9600.8.N.1)

PLC Station Number

COM0 Port D8116=H2 D8110=H81 D8111

COM1 Port D8126=H2 D8120=H81 D8121

COM1 Port D8266=H2 D8260=H81 D8261

»  COM0 Port Settings
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»  COM1 Port Settings

»  COM2 Port Settings
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§ Case 16: How to implement communication between HMI and Inovance AC drives?

Requirements

Use Inovance HMI to implement Modbus protocol communication with Inovance AC 
drives, to:

1.	 Control operation frequency of AC drives.

2.	 Control the forward and reverse running of AC drives.

3.	 Read the maximum frequency of AC drives.

Purpose

1.	 Learn how to set communication parameters when communicating with Inovance 
AC drives under the Modbus protocol.

2.	 Learn how to conduct wiring when communicating with Inovance AC drives under 
the Modbus protocol.

Descriptions

1.	 The Modbus protocol supports one-to-many communication between Inovance HMI 
and Inovance AC drives. HMI serves as the Modbus master station, and the AC 
drives work as the Modbus slave station.

2.	 Inovance MD380 AC drive doesn’t have 485 communication interfaces, and needs a 
communication expansion card MD38TX1.

3.	 As Inovance AC dr ives MD210, MD310 and MD280 are equipped with 
communication interfaces, no communication card is needed.

4.	 Inovance HMI is equipped with a specialized drive “Inovance Transducer” for 
Inovance AC drives. During the programming, just use corresponding Inovance 
Modbus addresses, or choose the Modbus-RTU protocol.

5.	 Introduction of Modbus addresses of Inovance AC drives: For example, F0-10 
address: The function code of an Inovance AC drive is composed of two parts, of 
which, the high byte.

F0 belongs to the parameter group and is represented with hexadecimal numbers; the 
low byte 10 is a function code, and is represented with decimal numbers. Its Modbus 
address:
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1)	 For F0-10, if a hexadecimal address is needed, the low byte must be converted into 
hexadecimal numbers. The combined Modbus address is F00A.

2)	 As some host computers require decimal read addresses for communicating 
with AC drives, in such cases, the corresponding address of the AC drive will be 
converted from F00A back to the decimal address, K61450.

3)	 Meanwhile, it should be noticed that as for function code data of F0 to FF, the high 
bytes of relevant communication addresses, based on whether they will be written 
to EEPROM, can be classified into 00 to 0F and F0 to FF. The low bytes are simply 
the sequence numbers of function codes in the function group. For example, while 
writing function data F0-16:

»  When it doesn’t need to be written to EEPROM, its communication address is 0010H.

»  When it needs to be written to EEPROM, its communication address is F010H.

Communication Cable Selection and Pin Definition

1. HMI DB9 female and male pins are defined as follows：

1)	 DB9 Female Pins: Communication ports including COM1[RS485 2/4W], COM3 
[RS485] and COM3 [RS232] on the back of the housing, which are used to connect 
controllers with RS485, RS422 and RS232 communication ports (COM1[RS485] 
4-wire is COM1 [RS422]). Refer to the table below for the pins arrangement.

Pin No.

Signal
DB9 Female 

Pins 
Arrangement

COM1 
[RS485] 
2-wire

COM1 [RS422]
COM3 

[RS485]
COM3 [RS232]/

COM2 [RS232]※

1 RS485- RX- (Receive negative)
2 RS485+ RX+ (Receive positive)
3 TX- (Transmit negative)
4 TX+ (Transmit positive)
5 GND (Signal ground)
6 RS485-
7 TXD (Transmit)
8 RXD (Receive)
9 RS485+

※1. Model IT5043T uses COM2 [RS232], and other models use COM3 [RS232].

※2. Serial ports can be used to connect serial port printers. Please refer to the 
commissioning software help for detailed setting.

2)	 DB9 Male Pins: COM1 [RS232]/COM2 [RS232]. This port is used to connect 
controllers with RS232 communication port. Refer to the table below for the pins 
arrangement.
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Pin No.
Signal DB9 Male Pins 

Arrangement
COM1 [RS232] COM2 [RS232]

1

2 RXD (Receive Data)

3 TXD (Transmit Data)

4 TXD (Transmit Data)

5 GND (Signal Ground)

6 RXD (Receive Data)

7 RTS (Ready for Transmit)

8 CTS (Clear Transmit Input)

9

2.  Inovance AC drive communication ports

1)	 The standard interfaces of the expansion card for an AC drive are 485+ and 485-. 
Use COM1 or COM3 of HMI to communicate with the AC drive simply by positive-to-
positive and negative-to-negative connection.

AC Drive Parameter Setting Table

1)	 Slave Station 1 Function Code Setting:

Function Code Value Function Code Description

F0-02 2 The command source is given by communication

F0-03 9 The frequency source is given by communication

FD-00 6005 The baud rate is 9600

FD-01 0 The communication format is 8.N.2

FD-02 1 The local address is 1

FD-05 31 Standard MODBUS communication format

2)	 Slave Station 2 Communication Format Setting:

Function Code Value Function Code Description

F0-03 9 The frequency source is given by communication

FD-00 6005 The baud rate is 9600

FD-01 0 The communication format is 8.N.2

FD-02 2 The local address is 2

FD-05 31 Standard MODBUS communication format

◆ In the case of communication with multiple AC drives, all parameters settings are the 
same except for FD-02. HMI identifies the connected AC drives through relevant station 
numbers.
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Programming Procedure

1. HMI Communication Parameter Setting

1)	 Add a PLC Device: From “Project management” > “Device” > “Local”, choose 
corresponding COM port, and right-click “Add device”.

2)	 Additional Instructions: If multiple AC drives are connected, click COM1, and then 
choose “Add Device” again:

»  In the “Device” dialog box that is displayed, for ”Device model” field, select “Inovance 
AC drive” or Modbus_RTU from the “Device model” drop-down list. If an AC drive from 
other manufacturers is used, only choose Modbus_RTU.

  

3)	 Click “Set” button on the above figure to open the following dialog box, in which 
set the data format as desired, and the settings must be consistent with parameter 
settings of the AC drive FD group.
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4)	 On the HMI window, add the parameter address of the AC drive, and then establish 
the communication.

»  Settings of communication addresses: When an AC drive is added, there will be two 
address types used to control different AC drives.

2. Introduction of MODBUS Addresses Corresponding to HMI:

InoTouch Editor software has multiple device types for the MODBUS protocol, including 
0x, 1x, 3x, 4x, 5x, 6x, as well as 4x_bit and 3x_bit, etc. The function codes supported by 
these device types under the MODBUS protocol are described below.

1)	 0x:  It is a readable and writable device type, equivalent to operating the output 
point of the PLC. When it is in reading status, it gives a function code of 01H, while 
in writing status, it gives a function code of 05H.
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2)	 1x: It is a read-only device type, equivalent to reading the input point of the PLC. 
When it is in reading status, it gives a function code of 02H.

3)	 3x: It is a read-only device type, equivalent to reading the analogue variable of the 
PLC. When it is reading data, it gives a function code of 04H.

4)	 4x: It is a readable and writable device type, equivalent to operating data registers 
of the PLC. When it is reading data, it gives a function code of 03H, and when it is 
writing data, it gives a function code of 10H.

5)	 5x: This device type has the same attributes as 4x. That is, function codes given 
by them while reading or writing data are exactly the same. What’s different is that, 
in the case of double bytes, for example, 32_bit unsigned data, when reading data 
with 5x and 4x, the position of high byte and low byte are reversed. For example, if 
4x device type reads 0x1234, 5x device type reads 0x3412.

6)	 6x: It is a readable and writable device type. When it is reading data, it also gives a 
function code of 03H. What’s different with 4x is that when it is writing data, it gives 
a function code of 06H, which means data for writing a single register.

7)	 3x_bit:  The function codes supported by this device type are the same as 3x device 
type. What’s different is that, 3x reads data, while 3x_bit reads the status of a 
certain bit in the data.

8)	 4x_bit:  The function codes supported by this device type are the same as 4x device 
type. What’s different is that, 4x reads data, while 4x_bit reads the status of a 
certain bit in the data.
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§ Case 17: How to implement communication between HMI and Inovance servo?

Requirements

Use Inovance HMI to implement Modbus protocol communication with Inovance servo, 
to:

1.	 Control and read servo speed through communication.

2.	 Enable servo.

Purpose

1.	 Learn how to set communication parameters when communicating with Inovance 
servo under the Modbus protocol.

2.	 Learn how to conduct wiring when communicating with Inovance servo under the 
Modbus protocol.

Descriptions

1.	 The Modbus protocol supports one-to-many communication between Inovance HMI 
and Inovance servo. HMI serves as the Modbus master station, and the servo works 
as the Modbus slave station.

2.	 The Inovance servo is equipped with 485 communication interfaces.

3.	 Inovance HMI is equipped with a specialized drive “Inovance Servo” for Inovance 
servo. During the programming, just use corresponding Inovance Modbus 
addresses, or choose the Modbus-RTU protocol.

4.	 Introduction of Modbus addresses of Inovance servo: For example, H02-10 address: 
The function code of an Inovance servo is composed of two parts, of which the high 
byte.

H02 belongs to the parameter group and is represented with hexadecimal numbers; the 
low byte 10 is a function code, and is represented with decimal numbers. Its Modbus 
address:

1)	 For H02-10, if a hexadecimal address is needed, the low byte must be converted 
into hexadecimal numbers. The combined Modbus address is H020A.

2)	 As some host computers require decimal read addresses for communicating 
with AC drives, in such cases, the corresponding address of the AC drive will be 
converted from H020A back to the decimal address, K522.

Communication Cable Selection and Pin Definition

1. HMI DB9 Female and Male Pins Are Defined as Follows:

1)	 DB9 Female Pins: Communication ports including COM1[RS485 2/4W], COM3 
[RS485] and COM3 [RS232] on the back of the housing, which are used to connect 
controllers with RS485, RS422 and RS232 communication ports (COM1[RS485] 
4-wire is COM1 [RS422]). Refer to the table below for the pins arrangement.
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Pin No.

Signal
DB9 Female Pins 

ArrangementCOM1[RS485] 

2-Wire
COM1 [RS422]

COM3

[RS485]
COM3 [RS232]/

COM2 [RS232]※

1 RS485-
RX- (Receive 

Negative)

2 RS485+
RX+ (Receive 

Positive)

3
TX- (Transmit 

Negative)

4
TX+ (Transmit 

Positive)

5 GND (Signal Ground)

6 RS485-

7 TXD (Transmit)

8 RXD (Receive)

9 RS485+

※1. Model IT5043T uses COM2 [RS232], and other models use COM3 [RS232].

※2. Serial ports can be used to connect serial port printers. Please refer to the 
commissioning software help for detailed setting. 

2)	 DB9 Male Pins: COM1 [RS232]/COM2 [RS232]. This port is used to connect 
controllers with RS232 communication port. Refer to the table below for the pins 
arrangement.

Pin No.
Signal

DB9 Male Pins Arrangement
COM1 [RS232] COM2 [RS232]

1

2 RXD (Receive Data)

3 TXD (Transmit Data)

4 TXD (Transmit Data)

5 GND (Signal Ground)

6 RXD (Receive Data)

7 RTS (Ready for Transmit)

8 CTS (Clear Transmit Input)

9



Section 7 Communication                                                                             

- 82 -

7

2. Pins of Inovance Servo Communication Ports Are Defined as Follows:

No. Definition Description Terminal Pin Arrangement

1

Reserved Reserved Terminal

1

2

3

4

5

6

8

7

2

3

4 RS485+

5 RS485-

6
RS232 transmitting terminal, 
connecting with the receiving 
terminal of the host computer

7
RS232-

RXD

RS232 receiving terminal, 
connecting with the transmitting 
terminal of the host computer

8 GND Ground

Housing PE Shielding

Use COM1 or COM2 of HMI to communicate with the servo. Connect the positive to 4and 
the negative to 5.

Servo Parameter Setting Table

Function Code Value Function Code Description

H0C-00 1 Servo Axis Address

H0C-02 2 Serial Port Baud Rate 9600

H0C-03 0 MODBUS Data Format 8.N.2

H06-02 4 Given Communication speed

H02-00 0 Mode: Speed Mode

H0C-09 1 Virtual DI Enabling

Note
 In the case of communication with multiple servos, all parameters settings 
are the same except for H0C-00. HMI identifies the connected servos through 
relevant station numbers.

Programming Procedure

1. HMI Communication Parameter Setting

1)	 Add a PLC device: From “Project management” > “Device” > “Local”, choose 
corresponding COM port, and right-click “Add device”.
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2)	 If multiple servos are connected, click COM1, and then choose “Add Device” again.

3)	 In the “Device” dialog box that is displayed, for “Device model” field, select “Inovance 
Servo” or Modbus_RTU from the “Device model” drop-down list. If a servo from 
other manufacturers is used, only choose Modbus_RTU. 

4)	

5)	 Click “Set” button on the above figure to open the following dialog box, in which 
set the data format as desired, and the settings must be consistent with parameter 
settings of the servo H0C group.



Section 7 Communication                                                                             

- 84 -

7

	

6)	 On the HMI window, add the parameter address of the servo, and then establish the 
communication.

Communication address setting: As Inovance servo addresses separate 16-bit data from 
32-bit data, three options are available for HMI to choose address types, of which:

»  function_code_32bit is for 32-bit addresses, such as function codes H0507, H0509, 
etc.

»  function_code_16bit is for 16-bit addresses, such as function codes H0200, H500D, 
etc.

»  function_code_reverse is for 32-bit addresses with high and low bytes reversed, 
equivalent to the Modbus 5X addresses.

2. Introduction of MODBUS Addresses Corresponding to HMI:

InoTouch Editor software has multiple device types for the MODBUS protocol, including 
0x, 1x, 3x, 4x, 5x, 6x, as well as 4x_bit and 3x_bit, etc. The function codes supported by 
these device types under the MODBUS protocol are described below.
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1)	 0x:  It is a readable and writable device type, equivalent to operating the output 
point of the PLC. When it is in reading status, it gives a function code of 01H, while 
in writing status, it gives a function code of 05H.

2)	 1x: It is a read-only device type, equivalent to reading the input point of the PLC. 
When it is in reading status, it gives a function code of 02H.

3)	 3x: It is a read-only device type, equivalent to reading the analogue variable of the 
PLC. When it is reading data, it gives a function code of 04H.

4)	 4x: It is a readable and writable device type, equivalent to operating data registers 
of the PLC. When it is reading data, it gives a function code of 03H, and when it is 
writing data, it gives a function code of 10H.

5)	 5x:  This device type has the same attributes as 4x. That is, function codes given 
by them while reading or writing data are exactly the same. What’s different is that, 
in the case of double bytes, for example, 32_bit unsigned data, when reading data 
with 5x and 4x, the position of high byte and low byte are reversed. For example, if 
4x device type reads 0x1234, 5x device type reads 0x3412.

6)	 6x:  It is a readable and writable device type. When it is reading data, it also gives a 
function code of 03H. What’s different with 4x is that when it is writing data, it gives 
a function code of 06H, which means data for writing a single register.

7)	 3x_bit:  The function codes supported by this device type are the same as 3x device 
type. What’s different is that, 3x reads data, while 3x_bit reads the status of a 
certain bit in the data.

8)	 4x_bit:  The function codes supported by this device type are the same as 4x device 
type. What’s different is that, 4x reads data, while 4x_bit reads the status of a cer-
tain bit in the data.

Note

Note: As Inovance servo MODBUS protocol communication supports function 
codes of

0X03 read registers

0X06 write a single register

0X10 write multiple registers

If use MODBUS_RTU as the communication device, 6X addresses must be used for 
reading and writing function codes of servo 16-bit registers.

4X addresses must be used for reading and writing function codes of 32-bit registers.
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§ Case 18: How to implement free protocol communication between HMI and Inovance 
PLC?

Requirements

1.	 Use HMI free protocol and PLC real time communication to modify PLC D0 values.

2.	 Read current data of PLC D2 in real time through the free protocol.

Descriptions

Free protocol: It is a customized communication format. When HMI doesn’t have a 
specialized protocol for communicating with a certain device, it can, based on protocol 
requirements of the device, use macro instructions and free protocol instructions (Out 
and In) to compile a communication protocol, in order to implement the data exchange 
between HMI and the device.

Programming Procedure

1)	 Start the HMI programming software to create a new project named “HMI and 
Inovance PLC comm. via free protocol”.

2)	 Click “OK” to open the following dialog box. Choose “Free Protocol” for “Device 
model”.

3)	 Choose COM1/COM2/COM3 for “Connect port” based on connected device.
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4)	 If COM port can’t provide required communication format, you can set through the 
system register.

 Addresses are shown as below:

5)	 This case uses COM1 port. The communication format is set to 9600 8 N 2, 
therefore LW9550=2, LW9551=2, LW9552=8, LW9553=0 and LW9554=0. The HMI 
communication format is set as below:

6)	 Two Functions Are Needed to Establish Communication With PLC Under the Free 
Protocol:

»  Out (Sending function: Sends data to serial ports via the free protocol)

»  In (Receiving function: Reads data from serial ports)

»  Write PLC D0 values (here, we take MODBUS as an example to describe the free 
protocol. For all other communication formats, communication can be established as long 
as you understand its communication protocol definition)
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7)	 Introduction of Major Macro Instructions:

int GetRxCrc(char c0, char c1)
{
  int x,y;
  x = c0;
  x &= 0xFF;
  y = c1;
  y &= 0xFF;
  return  x+y*256;
}

main()
{
  int nPos = 0;  //Pointer number in the buffer
  short nCrc = 0;    //crc code
  short nRxCRC = 0; //Received CRC return code
  bool bFlag  = false; /// Execution result flag
  int  nRdLen;   //Length read from the free protocol device
  int  nWrtLen;  //Write data into the length read from the free protocol device
  char RxBuf[256];  //Receive buffer
  char TxBuf[8] ;  // Transmit buffer
  short m1,m2;
 
  while (1)
  {
   m1=Get(“Local HMI”, LW, 9541,short);
         m2=Get(“Local HMI”, LW, 0,short);//Read LW0 data and write it into D0
   TxBuf[0]  =m1;  //Set the station number
   TxBuf[1]  = 0x06;  //Set the function code
   TxBuf[2]  = 0x00;  
   TxBuf[3]  = 0x00;//D0 Register address
   TxBuf[4] = HiByte(m2);
   TxBuf[5] = LoByte(m2);//Data written into D0
			   // Calculate CRC
   nCrc = CrcSum(TxBuf, 0, 6);
   TxBuf[6] = LoByte(nCrc);
   TxBuf[7] = HiByte(nCrc);
 
			   // Send data to PLC
   nWrtLen=Out("Free protocol device", TxBuf, 0, 8);
   //Written length
   Set("Local HMI",LW, 10, nWrtLen);

   // Read PLC return code
   nRdLen=In(("Free protocol device", RxBuf, 0, 9);
   Set("Local HMI", LW, 30, nRdLen);

Request frame format: 
Slave address

+0x06+ register address 
+ register value + CRC 

check

Response frame address: 
Slave address + 0x06+ 

register address + register 
value + CRC 

check.  Save to  RxBuf [ ] 
array
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Judgment of frame formats of received data

Judgment of communication results

   SetBlock("Local HMI", LW, 110, TxBuf, 0, 8);
   SetBlock("Local HMI", LW, 115, RxBuf, 0, 8);
   bFlag = false;

   if (RxBuf[nPos] == TxBuf[0]) // Station number judgment
   {
    if (RxBuf[nPos+1] == TxBuf[1]) // Function code judgment
    {
     if (8 == nRdLen) // Frame length judgment
     {

nRxCRC = GetRxCrc(RxBuf[nPos+6] , RxBuf[nPos+7] );
      nCrc = CrcSum(RxBuf, nPos, 6);
     if (nRxCRC == nCrc) // Checksum judgmeng
      {
       bFlag = true;
      }
     }
    }
   }

   
   if (bFlag)
    Set(“Local HMI”, LB, 0,true);
   else
    Set(“Local HMI”, LB, 0,false);
  }

}

»  Macro instructions for reading D2 data will not be described here.

8)	 PLC Program Setting:
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§ Case 19: How to use HMI to implement one machine with multiple screens, one screen 
for multiple machines, and Ethernet communication?

Introduction

HMI and PLC can implement one machine to one screen, one machine to multi-
screen, one screen to multi-machine, and multi-screen to multi-machine networking 
communication via Ethernet. The communication supports point-to-point data flow, 
and can deliver fast data exchange and easy networking. This paper focuses on the 
networking modes and methods of MODBUS TCP/IP in local area networks.

LAN

1. Definition:

Local Area Network (known as LAN) is a computer communication network by 
interconnecting various computers, peripheral equipment and databases within a local 
geographical range (such as a school, a factory or an organization), generally within a 
few kilometers.

2. Topological Structure

LAN has several topological structures, including circle structure, bus structure, tree 
structure, distributed structure and comprehensive structure, which will not be introduced 
one by one here. The following topological structure will be emphasized here, which is 
most widely applied in networking of HMI and PLC, as shown below:

The information contained in this message may be privileged and confidential. It is intended to 
be read only by the individual or entity to whom it is addressed or by their designee. If the 
reader of this message is not the intended recipient, you are on notice that any distribution of 
this message, in any form, is strictly prohibited. If you have received this message in error, 
please immediately notify the sender and delete or destroy any copy of this message.

Device 4

Device 3

Device 2

Device 1

Device N
Ethernet switch

Device 5

Figure 1 Topological Structure

http://baike.baidu.com/view/14702.htm
http://baike.baidu.com/view/1088.htm
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Note
In this chapter, a device in the topological structure diagram specially refers to HMI 
or PLC or a computer. When the device refers to a computer, it can read data from 
other devices through configuration software.

3. Production of RJ45 Plugs and Ethernet Cables

A RJ-45 plug is a plastic connector that can plug into relevant socket along a fixed 
direction and automatically avoid dropping out, known as the “crystal head”. Its technical 
term is RJ-45 connector (RJ-45 is a network interface specification). The reason why it is 
called “crystal head” is that

it has a transparent appearance like a crystal. Both ends of a twisted pair cable must be 
assembled with the RJ-45 plug, so that the cable can connect with a Network Interface 
Card (NIC), a Hub or a Switch through the RJ-45 interface, for network communication.

As for the production of RJ45 plugs, because color codes and relevant arrangement 
for twisted pair cables are strictly defined in international standards, just refer to such 
standards during the production. The commonly used standard is TIA/EIA568A/B.

1)	 568A standard: White-green, Green, White-orange, Blue, White-blue, Orange, 
White-brown and Brown.

2)	 568B standard: White-orange, Orange, White-green, Blue, White-blue, Green, 
White-brown and Brown.

Homogeneous (devices at both ends of the cable are of the same kind) crossover cable: 
One end conforms to 568A standard, and the other end conforms to 568B standard. 
Heterogeneous (devices at both ends of the cable are of different kinds) straight-through 
cable: Both ends conform to 568B standard.

Please refer to the following figure for production:

Figure 2 RJ45 Connector Diagram
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4.     Methods for Debugging Ethernet Devices

When a computer or a device is connected to the LAN through a cable, information such 
as IP address, subnet mask and gateway must be confirmed, and communication can be 
tested through the computer.

1)	 Self-test the network address of a computer.

»  Click “Start” > “Run”, and then input “CMD”, and click “OK”, as shown below:

Figure 3

2)	 Then, enter C:\WINDOWS\system32\CMD.exe interface.

»  Input “ipconfig” and press Enter key. Figure 4 shows the IP attributes of the computer.

Figure 4 IP Attributes of the Computer

3)	 As shown above, the IP address is: 192.168.1.100

»Subnet mask: 255.255.255.0

»Default gateway: 192.168.1.1

●● Set IP attributes of a device (which can be HMI or PLC).
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»  Set the IP address of a device according to IP attributes of the computer to make 
sure the device and the computer are in the same network segment. Therefore, the IP 
address is: 192.168.1.X, the subnet mask is: 255.255.255.0, and the default gateway 
is: 192.168.1.1. In the address, “X” must not interfere with IP of the computer or other 
devices.

●● Test the communication

»  Follow Step A to enter C:\WINDOWS\system32\CMD.exe interface, and then conduct 
ping test (IP of the device is 192.168.1.10). Input “ping 192.168.1.10” and press Enter 
key, as shown in figure 5, and figure 6.

Figure 5 Indicates That the Data Link Is Connected

Figure 6 Indicates That the Data Link Fails to Communicate

If there are multiple devices in the LAN, conduct the above tests one by one till all data 
links are connected. After the devices are ready for communication, conduct settings 
for MODBUS TCP/IP communication between devices. The following content mainly 
introduces settings for communication between HMI and PLC. In all the examples, HMI 
serves as the MODBUS TCP/IP master station and PLC works as the MODBUS TCP/IP 
slave station, which is the most commonly used way of communication between HMI and 
PLC in MODBUS TCP/IP networks.
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1)	 PLC Setting

»  AutoShop software setting, as shown in figure 7.

Figure 7 IP Address Setting

»  Among these settings, IP address of the PLC Ethernet slave station must be in the 
same network segment with the addresses of other devices in the LAN, and must not 
interfere with them. “ * “ in the IP address must be configured through dial on the H2U-
ENET-BD Ethernet card.

Figure 8 Download PLC Program

»  Check “Ethernet config” checkbox before downloading.
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2)	 Ethernet Card Setting

»  PLC must be equipped with a H2U-ENET-BD Ethernet card, as shown below:

                    

S2

S1

J5

CON 6

RJ 3

Φ 4mm

LED5

LED2

LED6

H1

H2

芯片

0

5

7 3

2
1

6 4

8
9

0

5

7 3

2
1

6 4

8
9

S2

S1

   Figure 9 Ethernet Card H2U-ENET-BD	            Figure 10 Dial Switch

»  Set the IP address of the PLC through the dial switch. In this example, a PLC’s IP 
address is set to 192.168.1.11.

Table H2U-ENET-BD Function Description

Printed 
code

Terminal Name Function

RJ45 RJ45 Interface Ethernet communication interface

S1 Code Dial The units digits of the last segment of the IP address (0 to 9)

S2 Code Dial
The tens digits of the last segment of the IP address (the range of 
tens digits + units digits is: 0 to 99)

H1/H2 Set Screw Holes Set screws for H2U-ENET-BD are M3*6 self-tapping screws

J5 Mini USB Reserved by the manufacturer

LED5
Communication 
Indicator (Green)

A flashing indicator indicates normal communication between the 
Ethernet and the PLC, and when there is no communication, the 
indicator will be OFF.

LED2
Communication 
Failure Indicator 
(Red)

A constantly ON red light indicates that the Ethernet card can't 
communicate with the PLC; and a flashing red light indicates 
communication failure between the Ethernet card and other 
devices. For detailed information about communication failure, 
refer to "8.6 Fault Code Information".

LED6 NIC Indicator -

CON6 Programing Port Reserved by the manufacturer

3)	 HMI Setting

»  InoTouch software setting

●● Firstly, add a device, as shown below:
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Figure 11  Add a Device

●● Choose “MODBUSTcp_RTU” for “Device model”, which means HMI is set as the 
MODBUS TCP/IP master station, as shown below. Then set the IP address of the 
connected PLC, with the port number of “502”.

Figure 12  Port Configuration

●● After confirmation, controls can be used to read/write the PLC address. As shown 
below.
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Figure 13  PLC Address Reading/Writing

Note
IAs the initial address of the shared register set in the figure 7 starts from 
D 200, HMI can access 100 addresses starting from D 200, and write 
addresses after hexadecimal conversion.

4)	 HMI Setting

»	 Restart HMI. Press the screen during the starting process, and then “Password” 
dialog box pops up, as shown in figure 14.

Figure14 Password Input Dialog Box

»  Input the default password “111111” to enter “setting” dialog box, as shown in figure 
15.
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Figure 15 System Setting

»  Click “NetWork” button to enter the dialog box for IP address setting, as shown in 
figure 16.

Figure 16 IP Address Setting (the IP address of HMI is 192.168.1.10).

5)	 Download HMI and PLC programs to relevant devices respectively, and connect 
them through the switch and cables. Make sure the data link is connected to 
implement data communication between HMI and PLC.

 One Screen to Multi-machine Communication

1)	 PLC Setting

»  Refer to the setting for one-machine to one-screen communication. It is only necessary 
to set the IP addresses of Ethernet cards of other PLC devices to make sure PLC IP 
addresses will not interfere with each other, nor interfere with the HMI address. Assume 
that another PLC has an IP address of 192.168.1.12.

2)	 HMI Setting

»  Based on the one-machine to one-screen setting, add another PLC device, as shown 
in figure 17. Assume that the new PLC has an IP address of 192.168.1.12, with the same 
port number of “502”.
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Figure 17

3)	 Then, set the PLC and relevant address to be accessed, as shown in figure 18.

Figure 18

4)	 After the setting is done, it is possible to access different PLC data, as shown in 
figure 19.

Figure 19
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5)	 With the same method, multiple PLC can be added to implement one-screen 
to multi-machine Ethernet communication. (For detailed number of PLC to be 
connected, please refer to “H2U Series Ethernet Communication Card Manual”)

One Machine to Multi-screen Communication

PLC Setting

»  Same as the PLC setting for one-machine to one-screen communication.

HMI Setting

1)	 InoTouch Software Setting

»  Software setting of each HMI is the same as that for the one-machine to one-screen 
communication, with the port number of “502”.

2)	 HMI Setting

»  IP addresses of all HMI in system setting must be in the same network segment and 
without conflicts. Please refer to figure 16.

Multi-machine to Multi-screen Communication

1)	 Refer to the HMI setting for one-machine to multi-screen communication and the 
PLC setting for one-screen to multi-machine communication, and make sure IP 
addresses will not conflict.

2)	 Essence of MODBUS TCP/IP networking.

»  MODBUS TCP/IP networking in essence means that multiple devices communicate 
with each other through the MODBUS TCP/IP protocol. The networking communication is 
feasible as long as the device supports this protocol.
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§ 8 Password, Alarm and Trend Display Controls

§ Case 20: How to use the password function to implement that page jumping can only be 
done with correct passwords?

Introduction

For now, Inovance HMI can support up to 12 users. Each user is classified into 7 classes, 
including “None” and “A to F”. A user password can be a combination of numbers (0 to 9), 
or characters, with a length of 8 bits.

 Six Questions Regarding Application of the Password Function

1.	 How to define initial passwords and permission classes of user 1 to user 12?

1)	 From Menu bar, choose “Edit” > “HMI system settings” to open the dialog box 
as shown below: Choose “User Password” tab to set the initial password and 
permission class of each user.

2)	 If check permission class A for user 1, and check permission class A and B for user 2, 
user 2 has higher permission level than user 1. User 2 can operate all controls that 
user 1 operates. This also applies to the other users.

2. 	 How to bind operation permission of controls to users?

1)	 Take “Number input” control as an example. Open the attribute setting dialog 
box of the number input control. Click “Security Attributes” tab, and then choose 
relevant operation type of this control under “User restriction”. This operation type is 
corresponding to user permission class in system settings.

2)	 If type A is chosen, find among user 1 to user 12 for users having A checked, who 
can all operate this control.
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3.	 How to enable the permission by inputting the relevant user name and password?

1)	 HMI defines special system registers used to set the user name and password.

»  User name: LW9219. Setting range is 1 to 12.

2)	 There are two types of user password: Digital password and character password. A 
digital password is for a number input control, with an address of LW9220, while a 
character password is for a character input control, with an address of LW9565.
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3)	 To show the password as *, choose “Numeric Format” tab of the number input/
character input control and then check “Password” checkbox, as shown below.

4.	 How to determine whether the entered password is correct?

1)	 HMI defines a special system status bit LB9060 used to determine whether the 
entered user name and password are correct.

2)	 When a wrong password is entered, [LB9060] is set to ON status; when a correct 
password is entered,  [LB9060] will automatically return to OFF status.

5.   How to online look up each user name and password, online modify passwords, and 
find out the current permission class?

1)	 HMI defines special system registers for 12 users, which are used to get the current 
user passwords. The addresses of digital passwords are LW9500 to LW9522, with 
totally 24 registers, every two of which are for one digital password. The addresses 
of character registers are LW9574 to LW9662, with totally 96 registers, among which 
each character password occupies 8 registers.

2)	 HMI defines a special system flag bit used to modify passwords. When system flag 
bit [LB9061] is turned from OFF status to ON status, HMI will take data in registers 
of LW9500 to LW9522 (or LW9574 to LW9662) as the latest passwords.

3)	 HMI defines a special system register LW9222 used to record the control types 
that can be operated by the current user. bit 0 of 1 means that the current user can 
operate controls of class “A”, bit 1 of 1 means that the current user can operate 
controls of class “B”; meanings of other bit numbers can be deduced in the same 
way.

6.	 How to log out after log in successfully? 

 There are two approaches:

1)	 HMI defines a special system status bit LB9050, which will force the current user to 
log out while turning from OFF to ON.

2)	 From Menu bar, choose “Edit” > “HMI system settings” and click “System Setting” 
tab to check “Auto logout” and set the logout time. If the logout time is set to 10 
minutes, the entered password will be canceled in 10 minutes, and the user needs 
to enter the password again in order to operate the control.
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3)	 Purpose of the password logout: After a password is correctly entered, if the user 
doesn’t log out, this control can be operated at any time without the necessity to 
enter the password again. Thus the password fails to offer protection.

Requirements

Screen switch can only be done with correct passwords.

Programming Procedure

1)	 From Menu bar, choose “Edit” > “HMI system settings” to set the initial password of 
user 1, as well as its password class.

	

2)	 Create a new password input page. This is a pop-up window and its width and 
height can be set as required.

3)	 The content of the page is shown below. If the user name and relevant password 
are correctly input, the current page will jump to the defined one. If the input 
password is wrong, fault information appears. The address of the user name is 
LW9219 while that of the password is LW9220.
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4)	 Press “Confirm” button to switch between pages. The security level is set to A. See 
the two figures below for the detailed settings.

	

5)	 Add a function key in the page to be switched from. This function key is used to pop 
up the password input window. From Menu bar, choose “Controls” > “Function key” 
to set its attributes, as shown below.

6)	 Perform offline simulation to implement the desired functions.
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§ Case 21: How to implement permitted operations of multiple users through the 
password function?

Requirements

1.	 For example, there are 6 users. If user 1 has the lowest permission level while user 
6 has the highest, user 2 can operate controls of user 1; user 3 can operate controls 
of user 1 and user 2, and so on.

2.	 When a user name and relevant password are correctly input, the password can be 
viewed or modified online.

Programming Procedure

1)	 From Menu bar, choose “Edit” > “HMI system settings” and then set the initial 
password and relevant operation permission class. To use character passwords, 
check “User character password” checkbox. This example is a window for digital 
passwords.

	

2)	 Add following controls on the initial window:
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3)	 User number is input via the number input box, the address is input via the special 
system register (or a drop-down list control). The setting is shown as below:

    

4)	 Digital password is input via the number input box, and the corresponding system 
register is set as below:

5)	 Operation classes of security attributes of 7 bit status transfer switches can be set 
respectively from “None” to “F”. Display relevant warning information when access 
is denied. Relevant setting is shown below:
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6)	 Add a bit status transfer switch for user logout, with the address of LB9050.

7)	 Create a new page and name it “Change password”. Set the page number to 2, as 
shown below:

8)	 Add 1 function key on the initial page to switch to the page for password change. 
The setting is shown as below:

Add number input boxes on the page for password change.

»  Add number input boxes for inputting user numbers and passwords (In the case of 
character passwords, add character input boxes). For the setting of number input boxes, 
refer to relevant settings on the initial page. 6 number input boxes are corresponding to 
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system registers of user1 to user 6 respectively, with addresses of LW9500 to LW9510, 
as shown below:

9)	 Set on the “Security Attributes” tab that hide the page when a user has no 
permission, as shown below:

10)	 As a modified user password can only be effective when the system status bit 
LB9061 is set to ON, a bit status transfer switch of “Renew password” is needed. 
Relevant setting is shown below:

11)	 “Back” button is used to return to the initial page. For its attribute setting, refer to the 
“Change password” function key.
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§ Case 22: How to implement the alarm function?

Requirements

When M100 is ON, the touch screen displays “Motor overload”. When M101 is ON, the 
touch screen displays “Servo fault”.

Programming Procedure

1. Create Alarming Information

1)	 Click “Project management” > “Event log table” to open the event registration table.

»  As shown in the figure below, choose “New event”.

Right click on this bar 
and select “New 
Event”

2)	 “Alarm event login” dialog box pops up.

»  On “General Attributes” tab, choose BIT for “Address type”, ON for “Triggering 
conditions”, and M100 for “Read address”.
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On “Information” tab, input “Motor overload!” in “Contents” field:

 

»  Now, alarming information of M100 is successfully created. Repeat steps 2 to 4 to 
create alarming information of M101.

3)	 If previous alarming information needs to be referred, it is necessary to choose a 
save path for alarming information. Repeat Step 1 and then right-click to choose 
“Save Mode” to save to “Local HMI” or a U disk or a SD card, as shown below:

2. Create Alarm Bars, Alarm Lists and Event Lists:

1)	 From Menu bar on the project page, choose “Controls” > “Alarm bar”/”Alarm 
list”/”Event list”.
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»  “Event display”: It records the whole process from the event is displayed upon 
triggered to the event restores. It can display the date when the “Event” occurs and the 
time when the operator confirms it, as well as the time when the “Event” restores. And 
when the “Event” is restored, its content will not disappear but relevant text color will 
change. In addition, “Event display” can be used to look up “Event records” on other 
dates through “History” mode.

»  “Alarm display”: It displays corresponding alarm information when the triggering 
condition is met. It can also display detailed date and time when the alarm occurs. 
However, when the “Alarm” is restored, all alarm information displayed including date 
and time will disappear. In other words, “Alarm display” only shows current “Alarm”.

» Like “Alarm display”, “Alarm bar” can only display the current “Alarm” in a single line 
with the scrolling manner. When the “Alarm” is restored, the text disappears. This control 
is generally used to display advertising text.

»  The result is shown below:

	

»  Green words in the event list indicate the time when M100 and M101 are turned from 
ON to OFF, displaying the even restoring time. When M100 and M101 are OFF, the 
display is shown as below:

»  When “History” mode is adopted for event lists, history alarm data can be referred 
through history control words. Detailed steps are shown below. Double-click the event list 
to open the following dialog box:

»You can choose control addresses in this dialog box. In this case, the address is D0, 
and a number input box can be added on the touch screen for D0. When D0 is zero, 
alarms of today will be displayed; when D0 is 1, alarms of yesterday will be displayed; 
when D0 is 2, alarms of the day before yesterday will be displayed; and so on.
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§ Case 23: How to implement the trend display function?

Requirements

Use history trend display and history data table controls of HMI to display the change 
curves of 5 PLC temperature data of D100 to D104. And previous data can also be 
referred.

 Programming Procedure

1)	 Establish the data sampling:

»  Click “Project management” > “Sampling data table” to open “Data Sampling” dialog 
box, as shown below: 

 

»  Choose D100 for “Read address”. As five temperature data will be read in this case, 
this address works as the initial address and all addresses include D100 to D104.

»Choose “Cycle” for “Sampling mode” with a time of 2 minutes, as shown below:
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»Set “Data type” of “Data record” to “16-bit Unsigned”. As we will record values of 5 D 
registers, press “Add” button to add 5 data. D100 is “Annealing zone 1 temperature”,D101 
is “Annealing zone 2 temperature”, and so on. “Maximum data amount” can be set 
with a bigger value of 80000, (sample 5 data every 2 minutes, 24 hours a day, totally 
24*60/2=720 times of sampling, and therefore 80000/5/720=22 days) as shown below:

»  Save it to the local HMI or a U disk or a SD card (if it is saved in a peripheral unit such 
as a U disk, the U disk must be connected to the touch screen all the time). In this case, 
“Retention period limit” is unchecked. Therefore, when data reaches its maximum of 
80000, previous data will be automatically cleared.

»  Now, data sampling is successfully established.

2)	 Establish history data table:

  »  From Menu bar, choose “Controls” > “History data table” to open the following page.

»  Double-click the control to pop up “History data display” dialog box. On “General” tab, 
set “Control address” to D2 and “Address of days” to D4, as shown below:
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»  Check “Display” under the “Channel” 0 on “Data Format” tab. As temperature values 
contain a decimal point, set “Digits before decimal point” to 3 and “Digits after decimal 
point” to 1. Then click “Property copy to other channels”, as indicated by the arrow in the 
figure below:

»  Enter words to be displayed in “Title” column on the “Title” tab, as indicated by the 
arrow in the figure below:

Display history records of 
more than one day. For 
example, if this value is 2, 
sampling data saved in the 
last 2 days is displayed.

Used for  speci fy ing the 
date of history. If this value 
is 0, sampling data saved 
today is displayed; if it is 
1,  sampl ing data saved 
yesterday is displayed, and 
so on.
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»  Press “OK” button to complete the history data table, as shown below:

»  The control address value must be changed to display data of yesterday or the day 
before yesterday. As previously the control address is set to D2, a number input box 
must be added for D2, through which the date of sampling data to be referred can be 
determined, as shown below:
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3)	 Create a trend display:

»  From Menu bar, choose “Controls” > “Trend Display”, and the following figure appears:

»  Double-click the control, check channels to be displayed on “Channel” tab, and set 
attributes of channel trend lines such as color, maximum values and minimum values.

»  Each trend line must have a different color for easy identification; the maximum value 
must be set according to the actual temperature. As in this case, the highest temperature 
is 450 degrees centigrade plus a decimal point, the maximum value is set to 4500. As 
indicated by the arrow in the following figure:

Set the trend line 
format separately 
for each channel 
number.

»  Now a real-time trend dispaly is successfully created, as shown below:
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»  For personalized requirements, different styles can be selected on the “Trend display” 
tab. For example, hide grids, as shown below:

	

»  For easy identification of temperature functions corresponding to each trend line, static 
description can be added at the bottom of the trend display, as shown below:
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§ Case 24: How to calculate storage capacity for history data and history events?

1. Learn how to calculate the storage capacity for history data and history events.

1)	 The local FLASH of HMI has a limited storage space of 128M, of which about 68M 
is for users. A large amount of data and events are continuously saved during 
sampling, which will take up the program space of HMI. When saved data reach 
the upper limit of local storage of HMI, HMI will alarm and pop up the following 
dialog box to indicate that a HMI/U disk or /SD card doesn’t have enough space for 
storage.

2)	 If a large amount of history data or history events have to be stored for user 
programming, it is recommended that SD card or U disk is used for storage. As 
to methods for storage with a U disk or SD card, please refer to cases of alarm or 
trend display; meanwhile, it can be set to clear history records at a specific time. It 
is recommended that history data is backed up regularly within the set time. In this 
way, normal data use can be guaranteed. (It is also OK to use the local storage 
of HMI, but in such a case, data backup must be done with a proper time interval, 
which can be determined based on the amount of sampling data, and then empty 
the local data of HMI.)

3)	 HMI is not a PC, without theoretically infinite space for storage. Please consider 
such factors during application.
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2. Storage capacity calculation method

1)	 Calculation of storage capacity for history events:

»  As each event has 12 bytes, and it will be multiplied by 12 bytes each time an event 
occurs.

1)	  Calculation of storage capacity for history data:

»  As to the following sample data: There are 4 data in “Data format”, all of which are 16-
bit addresses.

»  Every sampling needs 8 bytes. Every sampling takes 0.2 seconds. Therefore, there 
are 24*3600/0.2=432000 times of sampling every day.

432000*8=3456000. That is to say, if the machine runs for 24 hours, a capacity of 
3456000 bytes is needed per day, which is a capacity of 3.456m
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§ 9 Macro Instruction

§ Case 25: How to implement automatic page switching after a delay of 5s?

Requirements

After HMI is powered on and enters the main page for 5S, it checks the value of LW0. If 
LW0<=2, HMI enters no. 2 page, otherwise it enters no. 3 page.

Case Application

1.	 Automatic page switching based on time.

2.	 Automatic selection of pages to be switched based on project requirements.

Programming Procedure

1)	 Create a new project file named “Automatic page switching through macro 
instructions”.

2)	 Create 3 new pages, named “Page one”, “Page two” and “Page three”.

3)	 Click “Project management” > “PLC control table” > “Switch basic window” > “Control 
address”, set the address to LW10. Remember to check "Address returns to zero 
after a page switchover".

4)	 From Menu bar, choose “Tool” > “Macro Instruction” to enter the instruction edit 
page, and then click “Add” to create a macro named “Auto change page after delay 
time”.
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5)	 In the editing zone, enter the macro instructions in the main(){ } function.

6)	 Analyze the topic: after HMI is powered on and enters the main page for 5S, it 
judges the value of LW0 . If LW0<=2, HMI enters the number 2 page, otherwise it 
enters the number 3 page.

»  As the judgment is done with a delay of 5S, a delay function Delay(5000) is needed to 
implement the delay of 5s.

»  Here, to read data of LW0, a variable must be defined, which is PageNum in this case.

»  For judgment of the current value of LW0, the comparison statement IF ……else is 
used.

»  For page switching, the address of “Switch basic window” defined in “PLC control 
table” is used.

7)	 Macro instruction calling:

»  Click “Project management” > “PLC control table” > “Execute macro” , choose LW9000 
for “Control address” (after restarting, the status is ON), and set “Trigger mode” to “Always 
execute when the status is ON”.
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§ Case 26: How to use macro instructions to implement a calculator with functions of 
addition, subtraction, multiplication and division?

Requirements

Implement a simple calculator with functions of addition, subtraction, multiplication and division.

 Purpose

This case aims to understand how to conduct addition, subtraction, multiplication 
and division calculation through HMI macro instructions, based on which addition, 
subtraction, multiplication and division of floating numbers, as well as relevant calculation 
of extracting, sin cos can be conducted.

Programming Procedure

1)	 Create a new project file, named “Realization of a calculator”.
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2)	 Macro instructions and relevant comments:

3)	 The “Equal sign” button is a “Bit status transfer switch”. The “Switch type” is set to 
“Momentary switch”, which is a switch without self-lock and will automatic reset after 
triggering, used to call macro instructions.

	

4)	 This case adopts SWITCH……CASE statement to implement calculation of addition, 
subtraction, multiplication and division.

»  Multiple status setting controls are used to identify current status of addition, 
subtraction, multiplication and division, all with address LW0.

●● LW0=1 indicates addition; =2 indicates subtraction; =3 indicates multiplication; =4 
indicates division.

●● Macro instructions conduct corresponding calculation by judging the status of LW0.

  »  Calculation is done by calling macro instructions through the equal sign button.

●● As to 3HMI addition, subtraction, multiplication and division, two operands must 
be assigned to defined variables firstly. After relevant operations, such variables 
will then be assigned to corresponding registers. HMI or device addresses can’t be 
calculated directly.



                                                                                                                                                     Section 9 Macro Instruction

- 125 -

9

§ Case 27: How to implement immediate storage of data in the power-off retention area, 
through macro instructions?

Requirements

Implement immediate storage of data in the power-off retention area.

 Purpose

In HMI , RW and RW_A are areas for power-off retention. As it takes dozens of seconds 
for HMI to scan and store new data into HMI, if power failure occurs suddenly during the 
process, even though data are written in RW area, they may not be stored. Therefore, 
macro instructions are necessarily used to implement the immediate storage.

Programming Procedure

1)	 Create a new project file, named “Immediate data storage for power-off retention 
areas.

2)	 Compile macro instructions, as shown below:

3)	 Macro instruction code introduction

»  LB 9029 is the address of the system register. It is used to compulsively store recipe 
data to HMI (Set to ON).

main()

{

»  Set LB9029 to ON, and delay 200ms to OFF, equivalent to a compulsive storage.bool 
a=true;

bool b=false; // Define two BOOL variables a and b to be respectively true and false.

Set(“Local HMI”, LB, 9029, b); // Firstly, initialize LB9029 to false.Delay(200);	 / /  d e l a y 
200ms.

Set(“Local HMI”, LB, 9029, a); // Then set LB9029 to true. Delay(200);

Set(“Local HMI”, LB, 9029, b); // Finally set LB9029 to false.

}
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» In this statements, firstly initialize LB 9029 to false, then set it to true. Now according 
to the function of LB 9029, it implements storage operations. Finally initialize LB 9029 to 
false again, for next operation. Data storage is implemented through status changes of 
LB 9029.

4)	 Macro instruction execution

»  Add a number input control, with the macro instruction execution mode of “Execute 
after writing”, as shown below:

5)	 Similarly, in the case of multiple number input controls, immediate storage can be 
implemented by executing the macro instructions as well.

6)	 New data can be stored in HMI immediately after the completion of number input, 
which is implemented by compiling above macro instructions and setting the number 
input control.
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§ Case 28: How to use macro instructions to implement the control of PLC bit addresses 
through HMI register addresses?

Requirements

Use register LW0 of HMI to control Y0 to Y17 outputs of PLC

Purpose

This case aims to show how to use “FOR” loop statements in macro instructions and how 
to call macro instructions.

Programming Procedure

1)	 Create a new project file, named “LW0 Control Y0 to Y17 Output”, as shown below:

2)	  Macro instructions and relevant comments:

»  Use “FOR” loop statements to assign values of 16 bits of LW0 to Y0 to Y17 
respectively.

3)	 Macro instruction calling:

»  Add a “Bit status setting” control on HMI window, and then open “Bit status setting” 
dialog box, on “General” tab, set “Switch type” to “Set ON when window is opened”.
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4)	 Click “Project management” > “PLC control table” > “Execute macro”, and then set 
parameters, as shown below:

5)	 Offline simulation result: For example, as to an output of 1023, the binary number is 
1111111111, which is Y0 to Y11 output.
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Note Here, a “Bit status setting” control is used, with its “Switch type” set to “Set ON 
when window is opened”. This control can also call macro instructions, So why 
are they called in the PLC control table?

Macro instructions in the PLC control table can be executed as long as relevant 
conditions are satisfied, while those called by other controls can be executed 
for only once, not always, when relevant conditions are satisfied. Please pay 
attention to such difference.

§ Case 29: How to make a download progress bar through macro instructions?

Requirements

Make a download progress bar

Purpose

This case mainly illustrates joint application of functions related to bar chart, macro 
instruction and direct window.

Programming Procedure

1)	 Create a new project file, named “Make a download progress bar”, as shown below:

2)	 Add a bar chart control and set relevant attributes

»  From Menu bar, choose “Controls” > “Bar Chart” to add a bar chart control.

»  Adjust the control size according to required length of the download progress bar, as 
shown below:

»  Double-click the bar chart control to set relevant attributes:
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»  As the download progress bar displays the progress rightwards, set “Display direction” 
on “Appearance” tab to “Display rightward”. Parameters such as “Max. value”, “Min. 
value” and “Color” can be set according to relevant project requirements.

»  Set the address of the register for download progress control on “General” tab. In this 
case, it is D0.

3)	 Add relevant controls:

»  From Menu bar, choose “Controls” > “Transfer Switch” > “Bit Status Transfer Switch” to 
add a transfer switch for controlling the start of downloading, with an address of LB1.

Status 0	 Status 1

»  From Menu bar, choose “Controls” > “Direct Window” to indicate the completion of 
downloading, with an address of LB1.

»  Add window 2, with a window size same as that of the direct window. Add following 
content on it:
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»  The “OK” button is a “Function Key” control. Choose “Close window” on the “General” 
tab and set the notice bit to close LB1, which means this window can be closed by 
closing the direct window.

4)	 Add a “Number input” and “Static text” control in the middle of the bar chart control 
to indicate the download progress.

5)	 Select all controls on window 1, and set the alignment to “Horizontal center”, as 
shown below:

Associate the controls with macro instructions to execute the download progress bar.

»  Macro instructions and relevant comments are shown as follows:

6)	 Choose “Execute macro” in PLC control table, and set that macro instructions are 
always executed when LB1 is ON

»  The simulation is shown below:
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»  Click “Start Download”:

»  After the download is finished, the dialog box below will pop up saying “Download 
Success!”:

§ Case 30: How to display and hide buttons?

Requirements

1.	 When LB0 is ON, LW0 can be enabled for data input. Otherwise, it is disabled.

2.	 When LB1 is ON, LW1 can be displayed and enabled for data input. Otherwise, it is 
hidden.

Purpose

This case aims to illustrate the “Enabled/Disabled” function on the “Security Attributes” 
tab of the main controls.

Programming Procedure

1)	 Create a new project file, named “Controls Hidden and Display”.

2)	 Add two bit status transfer switches, with respective addresses of LB0 and LB1.

»  From Menu bar, choose “Controls” > “Transfer Switch” > “Bit Status Transfer 
Switch”, and then set relevant attributes, as shown below:

3)	 Add number input registers LW0 and LW1, and then set relevant attributes.

»  From Menu bar, choose “Controls” > “Number/Character” > “Number Input Display” > 
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“Number Input” to add two

»  number input registers, with addresses of LW0 and LW1 respectively

»  Double-click register LW0 to enter the dialog box for attribute setting. On “Security 
Attributes” tab, check “Enabled” under “Enabled/Disabled”, and then check “Enabled 
when bit status is ON”, to implement the function that only when LB0 is ON, can LW0 be 
enabled.

»  Double-click register LW1 to enter the dialog box for attribute setting. On “Security 
Attributes” tab, check “Enabled” and “Hide when disabled” under “Enabled/Disabled”, and 
then check “Enabled when bit status is ON”, to implement the function that only when 
LB1 is ON, can LW1 be displayed and enabled.

4)	 The simulation is shown below:
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5)	 Click LW0, and there will be no response. When LB0 is set to ON, LW0 will be 
enabled for data input, and when LB1 is OFF, LW1 will be hidden, as shown above. 
When LB1 is ON, LW1 will be displayed and enabled, as shown below:
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§ 10 Download HMI and PLC Programs With an USB Disk, and The Pass-
through Function

 § Case 31: How to download HMI programs with an USB disk?

Requirements

1.	 Understand points to be observed when downloading HMI programs with an USB 
disk.

2.	 Learn how to download HMI programs with an USB disk.

Procedures

1. Step 1: Save HMI programs to an USB disk.

1)	 Plug an USB disk into the PC, and then choose “Tool” > “Create Files for Project 
Data” from Menu bar of the InoTouch Editor software.

2)	 Now the following dialog box pops up. If the USB disk is the G disk of the PC, data 
will be saved in the G disk. Check “Project file”, “Recipe data”, “Firmware” and “Font 
file” on the dialog box.
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3)	 Then press the “Create” button, and the dialog box will pop up saying “Creating item 
download data succeeded”. Now, HMI programs have been successfully saved to 
the USB disk.

2. Step 2: Preparation before plugging the USB disk into HMI:

1)	 Power on HMI (DC 24V). During power on, press and hold the touch panel, and the 
following login window will appear when the system is started:

2)	 Input the login password in “Password” field. The default password is 111111. After 
the password is correctly input, HMI will automatically enter “Setting” window. See 
the figure below. Click “DownLoad”.
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3)	 As shown on “Download” dialog box, check “Popup download window” and “Restart 
after download/upload”, and then click “OK” to close the dialog box.

4)	 Return to “Setting” window, and then click “Cancel” to close it.

5)	 Plug in the USB disk, and the following dialog box pops up. Click “usb disk1”, and 
then click “HMI Pro Update”.

3. Step 3: Download HMI programs.

1)	 Plug the USB disk into HMI, and the above window pops up. Open “usb disk1” 
to locate the HMI files saved in the USB disk. Then, click “HMI Pro Update” and 
download them according to required procedures.
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§ Case 32: How to download PLC programs with an USB disk?

Requirements

1.	 Understand points to be observed when downloading PLC programs with an USB 
disk.

2.	 Learn how to download PLC programs with an USB disk.

Case Key Points

1.	 Considerations during downloading PLC programs with an USB disk:

1)	 Make sure HMI communicates normally with PLC.

2)	 Make sure the PLC version is correct.

3)	 H2U-XP: 26136 or above; H1U-XP: 26127 or above; otherwise this function is not 
supported.	

Procedures

1. Step 1: Save PLC programs to an USB disk:

1)	 Start the PLC program. From Menu bar, choose “File” > “Make Download Files”, and 
then “Download File Option” dialog box pops up. Choose “Download option” and 
then click “Makefile”, as shown below:

2)	 Open the USB disk. Name the file “HC1”, and then a file of “HC1.down” will be 
generated and saved in the USB disk.
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2. Step 2: Preparation before plugging the USB disk into HMI:

1)	 Power on HMI (DC 24V). During power on, press and hold the touch panel, and the 
following login window will appear when the system is started:

2)	 Input the login password in “Password” field. The default password is 111111. After 
the password is correctly input, HMI will automatically enter “Setting” window. See 
the figure below. Click “DownLoad”.

3)	  As shown on “Download” dialog box, check “Popup download window” and “Restart 
after download/upload”, and then click “OK” to close the dialog box.
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4)	 Return to “Setting” window, and then click “Cancel” to close it.

3. Step 3: Download PLC programs.

1)	 Plug the USB disk into HMI. In the dialog box that pops up, click “PLC Pro Update” 
to update PLC programs, and the following dialog box appears:

2)	 Select a serial port at the HMI side for the connection between PLC and HMI. Click 
“usb disk1” drop-down list and select the previously saved HC1.down file. Then, 
click “Download” button to start downloading and then follow the prompts.

3)	 If click “Clear PLC programs”, PLC internal programs will be cleared. When it is 
finished, click “Exit” to safely exit the USB disk.
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§ Case 33: How to download PLC programs through HMI > Pass-through function?

The Pass-through function provided by InoTouch Editor software can use the PLC 
programming software installed on the PC, through the HMI connected to this PC, to 
connect to the PLC connected to this HMI. Thus, monitoring, downloading or uploading 
PLC programs can be conducted. At this point, InoTouch series HMI works as a 
converter. The Pass-through communication function has two modes, which are pass-
through communication with USB (virtual serial port) and that with Ethernet.

As shown above, PC and HMI are connected through Ethernet or USB, while HMI and 
PLC are connected via serial ports. For the convenience of debugging, PC can directly 
download or monitor PLC programs through HMI, to improve efficiency.

Procedures

1)	 From Menu bar, choose “Tool” > “Pass-through Tool” to open “HMI Pass Through 
Device” dialog box, as shown below:

2)	 Click “Add” button to add a virtual serial port. Here, it is COM6 (different PC 
configurations will have different serial port numbers):
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3)	 Double-click COM6, and then set the virtual device as shown below:

»  Pass-through communication with USB:

 

Select from here The mode 
of pass-through 
communication

The configuration is 
completed.
Click "Start pass-
through 
communication" 
button

Here is the connecting 
configuration between
HMI and PLC, corresponding 
to the actual connecting ports 
and communication formats 
between HMI and PLC

This serial port is a virtual device, 
corresponding to the port connecting to 
the PLC in the programming software

 

Select from here The mode 
of pass-through 
communication

The configuration is 
completed.
Click "Start pass-
through 
communication" 
button

Here is the connecting 
configuration between
HMI and PLC, corresponding 
to the actual connecting ports 
and communication formats 
between HMI and PLC

This serial port is a virtual device, 
corresponding to the port connecting to 
the PLC in the programming software

ETH

»  Pass-through communication with Ethernet:
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Select from here
the mode of pass-
through communication

Set the IP address 
of HMI here

 

Select from here The mode 
of pass-through 
communication

The configuration is 
completed.
Click "Start pass-
through 
communication" 
button

Here is the connecting 
configuration between
HMI and PLC, corresponding 
to the actual connecting ports 
and communication formats 
between HMI and PLC

This serial port is a virtual device, 
corresponding to the port connecting to 
the PLC in the programming software

ETH

4)	 Start the PLC programming software. Create a new project, and from Menu bar, 
choose “Tools” > “Communication Setting” to open “Communication Setting” dialog 
box.
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5)	 In this dialog box, set the serial port for connection between PC and PLC to a 
virtual port of the pass-through communication tool. In this case, the virtual serial 
port is COM6. When the configuration is finished, click “OK” button to save the 
configuration:

 

Select from here The mode 
of pass-through 
communication

The configuration is 
completed.
Click "Start pass-
through 
communication" 
button

Here is the connecting 
configuration between
HMI and PLC, corresponding 
to the actual connecting ports 
and communication formats 
between HMI and PLC

This serial port is a virtual device, 
corresponding to the port connecting to 
the PLC in the programming software

ETH

6)	 Return to the pass-through communication tool window and cl ick “Start 
Communicate” button to enable the virtual serial port.
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Select from here The mode 
of pass-through 
communication

The configuration is 
completed.
Click "Start pass-
through 
communication" 
button

Here is the connecting 
configuration between
HMI and PLC, corresponding 
to the actual connecting ports 
and communication formats 
between HMI and PLC

This serial port is a virtual device, 
corresponding to the port connecting to 
the PLC in the programming software

ETH

Now, it is ready to enter the PLC programming software to upload, download and monitor 
PLC data. In addition, connecting status can be monitored on the interface of pass-
through communication tool: If there is data exchange between AutoShop software and 
PLC, relevant status indication will change.

After PC and HMI are connected and 
the pass-through communication
is started, it will display "Connected" 
here

When AutoShop software is exchanging 
data with PLC,
it will display "Alive"

 

Select from here The mode 
of pass-through 
communication

The configuration is 
completed.
Click "Start pass-
through 
communication" 
button

Here is the connecting 
configuration between
HMI and PLC, corresponding 
to the actual connecting ports 
and communication formats 
between HMI and PLC

This serial port is a virtual device, 
corresponding to the port connecting to 
the PLC in the programming software

ETH
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§ 11 Import and Export Function

§ Case 34: How to import and export the Text Label Library?

Requirements

This case mainly introduces

1.	 How to establish a text label library

2.	 How to import and export a text label library

3.	 Advantages of using a text label library

 Procedures

1.	 How to establish a text label library:

1)	 Start the HMI programming software, and double-click “Text label library” in “Project 
management” at the left side of the software.

	

2)	  After the text label library is opened, the following figure appears, which shows text 
labels provided by the HMI programs.
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3)	 Right-click the text label library and choose “Add Text Label Item” to add a new text 
label.

Right-click within this area, 
the drop-down menu 

appears.

2.    Import and export the text label library:

1)	 Click anywhere on the text label library, right-click to open the shortcut menu, as 
shown below, and then choose “Export”.

Right-click within this area, and select 
“Export”on the drop-down menu.
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2)	 Then, the following dialog box appears.

3)	 Click the browse button to open “Save As” dialog box and then enter a name for the 
text label library.

4)	 Click “Save” button, and indication of successful export will be shown.
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5)	 The file is saved into the root directory of project file, which can be opened with 
EXCEL.

6)	  After the file is opened, text labels can be added according to formats of the text 
label library. For example, add a multi-status switch with totally 10 status. The status 
name is “Lab_StateLED”, and the text content is State01 to State10. It is required 
that the content is displayed in both simplified and traditional Chinese, which can be 
easily edited through EXCEL. The interface, after the editing is finished, is as shown 
below:

Right-click within this area, select 
“Import”on the drop-down menu.
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7)	 Save it, and then choose “Import” from the HMI text label library.

8)	 After imported, a new text label is added into the text label library: “Lab_StateLED”.

  



Section 11 Import and Export Function

- 151 -

11

9)	 Double-click to open the text label “Lab_StateLED”.

»  Status 1:

»  Status 2

10)	 Adjust the font:
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3.    From this case, we can learn that using the text label library has following 
advantages:

1)	 As content in the text label library is changed, texts of all controls that call the text 
label library will be changed accordingly, which makes the project modification and 
maintenance at a later stage more convenient.

2)	 The text label library can be exported, and then imported after being edited in Excel, 
which is faster and more convenient compared to making edit and adjustment in the 
software.

3)	 All texts in the text label library of the whole project can be quickly set with a unified 
font to guarantee the uniformity.

§ Case 35: How to import and export recipe data?

Requirements

This case mainly introduces the following two parts:

1.	 Establish and download recipe data.

2.	 Export recipe data saved in HMI into .CSV files through USB disks or SD cards.

Procedures

1.	 Establish and download recipe data.

1)	 Create a new recipe data table:

»Step 1: Start the HMI programming software, and choose “Project management” > 
“Recipe” > “Add Recipe”. Name the recipe as 13, and set addresses to RW0 to RW10. 
Namely, there are 5 recipes, with 2 fields for each recipe. As shown below.
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»  Step 2: Input the initial recipe data as shown below:

»  Step 3: When downloading programs including the recipe files, check “Recipe data” 
and then select the required recipe file. In this case, the recipe named 13 is used.
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»  Step 4: Check the recipe data after they are downloaded into HMI. Now, data of recipe 
addresses are those previously input in recipe 13.

2.	 Export recipe data saved in HMI into .CSV files through USB disks or SD cards.

1)	 Preparation:

»  Step 1: When HMI is powered off, press and hold HMI to open the following window:
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»  Step 2: Enter the initial password 111111, and then the following dialog box appears:

»  Step 3: Click “DownLoad” button to open the following dialog box:

»  Step 4: Check both the two options, so that when an USB disk or a SD card is 
inserted, the following dialog box will automatically pop up:
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2)	 Procedures for import and export:

»  Click “Export/Import” button on the above dialog box, enter the initial password 111111, 
and then the following dialog box appears.

Click “Recipe Import” or “Recipe Export” button to import or export the recipe as a CSV 
file.
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§ Case 36: How to import and export alarming data?

Requirements

This case mainly introduces the following two parts:

1.	 Import and export data of event log tables

2.	 Export alarming data saved in HMI into .CSV files through USB disks or SD cards

Procedures

1.	 Part 1: Import and export an event log table.

1)	 Export: Open the event log table and create a new event.

2)	 Then, right-click the new event and choose “Export” from the shortcut menu.

3)	  The following dialog box appears.
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4)	 Click the browse button to open the following dialog box:

5)	 Enter the file name here, and the default path is the root directory of the project file. 
Click “Save” button and it will indicate that the export is successful, as shown below:
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6)	 Open the project directory to locate the newly exported .CSV file.

7)	  After it is opened, the format is shown below

8)	 To add multiple events in batches, relevant editing can be done in the exported 
.csv file before it is imported. For example, this case adds LB10 to LB14 with fault 
information of alarming 1, 2, 3, 4, 5. After the editing, it is shown as follows:
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9)	 Import: Import the revised event log table.

»  Open the event log table, and right-click it to choose “Import” from the shortcut menu:

»  In the import dialog box, click the browse button to open the following dialog box:

  

»  Select the file to be imported and then click “Open”.
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»  The above dialog box appears, and then click “Import” on it.

»Click “Yes” and the newly established LB10 to LB14 will be successfully imported to the 
event log table.

	

10.	 Part 2: Export alarming information saved in HMI into .CSV files through USB disks 
or SD cards.

1)	 If it needs to be saved, 1. Choose the saving path: Open “Event log table” and right-
click it to choose “Save Mode” from the shortcut menu.

2)	 It can be saved into local HMI or in a SD card or an USB disk.

»  If it is saved directly into an USB disk or a SD card, it will be automatically saved as a 
.CSV file.

»  If it is saved into the local HMI, history events saved in the local HMI can be exported 
to the USB disk through the “Export/Import” function of HMI, for reference by people 
when needed.
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3)	 Export history events saved in HMI as a .CSV file.

»  Preparation:

●● Step 1: When HMI is powered off, press and hold HMI to open the following window:

●● Step 2: Enter the initial password 111111, and then the following dialog box appears:

●● Step 3: Click “DownLoad” button to open the following dialog box:
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●● Step 4: Check both the two options, so that when an USB disk or a SD card is 
inserted, the following dialog box will automatically pop up:

	

●● Step 5: Click “Export/Import” button and input the initial password 111111 to enter 
the following dialog box. The initial password can be changed through system 
settings.

NoYes

●● Choose “Event Export” to export, and successful exporting will be indicated as 
shown in the figure above.
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4)	 How to refer to the exported data on a PC?

»  Plug the USB disk into a PC, open the USB disk to locate “evt” folder, and then you 
will find the file named HMI_EL_20170424.CSV in this folder.

»  After open the file, data previously saved in HMI, including fault date, event, event 
content, can be referred to through EXCEL.
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§ Case 37: How to import and export history sampling data?

Requirements

This case mainly introduces how to export history sampling data saved in HMI into .CSV 
files through USB disks or SD cards.

Procedures

1.	 To make a trend display, please refer to the case for making a trend display.

2.	 If it is necessary to save history sampling data, the saving path must be selected in 
the sampling data table.

1)	 It can be saved into local HMI or in a SD card or an USB disk.

»  If it is saved directly into an USB disk or a SD card, it will be automatically saved as a 
.CSV file.

»  If it is saved into the local HMI, history events saved in the local HMI can be exported 
to the USB disk through the “Export” function of HMI, for reference by people when 
needed.
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2)	 Export history data saved in HMI into .CSV files.

»  Preparation:

●● Step 1: When HMI is powered off, press and hold HMI to open the following window:

Exit

●● Step 2: Enter the initial password 111111, and then the following dialog box appears:

●● Step 3: Click “DownLoad” button to open the following dialog box:

●● Step 4: Check both the two options, so that when an USB disk or a SD card is 
inserted, the following dialog box will automatically pop up:
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3.	 Procedures for import and export:

1)	 Click “Export/Import” button on the above dialog box, enter the initial password 
111111, and then the following dialog box appears.

2)	 Click “Sample Export” button. If the export succeeds, the following indication 
appears.

	

NoYes

3)	 How to refer to the exported data on a PC?

»  Plug the USB disk into a PC, open the USB disk to locate “sdl” folder, and then you will 
find the file named HMI_DataPath1_20170424.CSV in this folder.
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»  After the file is opened, data previously saved in HMI can be referred to through 
EXCEL, regarding the changing process of data.
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§ Case 38: How to access system settings, and what are the major functions of system 
settings?

Purpose

This case aims to show how to access the system menu and what functions can be 
implemented through the system menu.

How to Access the System Menu (Two Approaches)

1)	 Approach 1: When the system is powered on, press and hold any position of the 
touch panel, so that “Settings” interface appears after the system is started.

2)	 Approach 2: Add a function key on the HMI window: From Menu bar, choose 
“Controls” > “Function Key”, check “Display system menu” on “General” tab of 
“Function key” dialog box, and then “Settings” interface pops up.

3)	 For system safety, the password must be input before accessing the system 
settings. The default password is 111111. The following dialog box will pop up after 
the password is correctly input.
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1.	 Network: There are two approaches for setting the IP address of HMI:

1)	 Click “NetWork” button in system settings: The following dialog box will pop up for IP 
address configuration.

	

»  Automatic acquisition of the IP address: DHCP server of the LAN automatically assigns 
the IP address. At this time, InoTouch Editor HMI is just like a PC in the LAN.

»  Manual setting of the IP address: Applicable to direct connection between a PC 
and the HMI. Note: When HMI is directly connected to a PC through cables, static IP 
addresses of both the two must be set manually, and the two IP addresses must be in 
the same network segment. For example, IP of HMI is set to: 192.168.60.201, and thus 
IP of the PC can be set to: 192.168.60.202.



Section 11 Import and Export Function

- 171 -

11

2)	 Configure the IP address through special registers

2.	 Time/date setting: There are three approaches to set the time and date.

1)	 Click “Time/Date” button to enter the following dialog box to modify the current 
system time.

2)	 During the setting for HMI downloading, check “Sync. time”, so as to make the 
current time consistent with the PC time.
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3)	 Use special registers LW9017 to LW9023 for the configuration.

3.	 Security settings: A local password can be set, as well as passwords for uploading, 
downloading and uploading history.

1)	 Local Password: This password is used to access the system settings. The initial 
password is 111111.

2)	 Upload Password: This password is used for uploading programs. The initial 
password is 000000.

3)	 Download Password: This password is used for downloading programs. The initial 
password is 000000.

4)	 Upload (History) Password: This password is used when data such as recipe data 
and history sampling data are imported or exported through USB disks. The initial 
password is 111111.
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4.     History: It is used to clear recipe, eventlog and datalog saved in HMI.

1)	 Approach 1: Check relevant options in system settings to clear such information.

2)	 Approach 2: During setting for downloading, check the following three options to 
achieve the same effect as Approach 1.
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5.    Backlight/Rotation: Backlight brightness, as well as screen rotation angles, can be 
adjusted through this function.
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5.    Backlight/Rotation: Backlight brightness, as well as screen rotation angles, can be 
adjusted through this function.
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6.     Sound setting: Adjust the volume

1)	 When the slider is moved leftwards with your finger (or the mouse), sound will turn 
lower; when it is moved rightwards with your finger (or the mouse), sound will turn 
louder.  Or, click “-” to make sound lower, and click “+” to make sound louder.

Note  The sound adjustment is only applicable to IT5070E/IT5104E HMI with audio 
interfaces. It is not for the adjustment of buzzer sound.

7.	 Download:

1)	 The above two options must be checked when using an USB disk or a SD card to 
download PLC or HMI programs, or to import and export .CSV files of history data 
or alarming records.

2)	 When the USB disk is plugged again, the following dialog box pops up, from which, 
downloading of HMI and PLC programs, update of recipe data, and import/export of 
history data or alarming records can be selected.

3)	 EOH setting: It is used to set the initial screen that HMI displays when it is powered 
on.
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4)	 Language: It is used to implement the switchover among Chinese, English and 
Traditional Chinese.

5)	 Touch calibration: Click it to enter the calibration mode, and then 5 “+” spots will 
appear on the screen. Click the 5 spots one by one according to relevant prompts. 
The calibration will end automatically after adjustment is completed.



- 178 -

Revision History

Date Version Change Description

June 2017 A00 First issue.




	OLE_LINK10
	OLE_LINK16
	OLE_LINK17
	OLE_LINK16
	OLE_LINK17
	_GoBack
	§ 1 Image Library Function
	§ Case 1: How to draw figures by using drawing tools, and save them to Image Library?
	§ Case 2: How to Save Existing Images to Image Library?
	§ Case 3: How to call Image Library through controls? How to implement the transparent display of controls?

	§ 2 Direct Window and Indirect Window
	§ Case 4: How to create a pop-up menu?
	§ Case 5: How to make a help document for troubleshooting the AC drive?

	§ 3 Multi-Language and Text Label Library
	§ Case 6: How to implement multi-language switchover?

	§ 4 Screensaver Function
	§ Case 7: How to implement screensaver - approach 1
	§ Case 8: How to implement screensaver - approach 2

	§ 5 Animation, XY Curve and Dynamic Line Drawing
	§ Case 9: How to use animation controls?
	§ Case 10: How to draw a rectangle and a square by using XY curves?
	§ Case 11: How to draw an equilateral triangle with the Dynamic Line Drawing control?

	§ 6 Recipe
	§ Case 12: How to implement the recipe function?

	§ 7 Communication
	§ Case 13: How to implement HMI monitor protocol communication between HMI and Inovance PLC?
	§ Case 14: How to implement Modbus protocol communication between HMI and Inovance PLC?
	§ Case 15: How to implement QLink protocol communication between HMI and Inovance PLC?
	§ Case 16: How to implement communication between HMI and Inovance AC drives?
	§ Case 17: How to implement communication between HMI and Inovance servo?
	§ Case 18: How to implement free protocol communication between HMI and Inovance PLC?
	§ Case 19: How to use HMI to implement one machine with multiple screens, one screen for multiple machines, and Ethernet communication?

	§ 8 Password, Alarm and Trend Display Controls
	§ Case 21: How to implement permitted operations of multiple users through the password function?
	§ Case 22: How to implement the alarm function?
	§ Case 23: How to implement the trend display function?
	§ Case 24: How to calculate storage capacity for history data and history events?

	§ 9 Macro Instruction
	§ Case 25: How to implement automatic page switching after a delay of 5s?
	§ Case 26: How to use macro instructions to implement a calculator with functions of addition, subtraction, multiplication and division?
	§ Case 27: How to implement immediate storage of data in the power-off retention area, through macro instructions?
	§ Case 28: How to use macro instructions to implement the control of PLC bit addresses through HMI register addresses?
	§ Case 30: How to display and hide buttons?

	§ 10 Download HMI and PLC Programs With an USB Disk, and The Pass-through Function
	 § Case 31: How to download HMI programs with an USB disk?
	§ Case 32: How to download PLC programs with an USB disk?
	§ Case 33: How to download PLC programs through HMI > Pass-through function?

	§ 11 Import and Export Function
	§ Case 34: How to import and export the Text Label Library?
	§ Case 35: How to import and export recipe data?
	§ Case 36: How to import and export alarming data?
	§ Case 37: How to import and export history sampling data?
	§ Case 38: How to access system settings, and what are the major functions of system settings?

	Revision History

